summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2015-07-17 14:05:06 -0700
committerLlewelyn Trahaearn2015-07-17 14:05:06 -0700
commit068d8365dfbaa48b2d5e565865115c1553b044e6 (patch)
tree21efdc1f1fc5a9e4e07d54392bd8561cfc8f6c7e
downloadaur-068d8365dfbaa48b2d5e565865115c1553b044e6.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
-rw-r--r--gschemas.install20
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1fdbd5a7da0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-coverflow-alt-tab-git
+ pkgdesc = Alternate Alt-Tab behaviour: iterates through windows in a manner akin to Cover Flow.
+ pkgver = r104.db5bd2c
+ pkgrel = 1
+ url = https://github.com/dmo60/CoverflowAltTab
+ install = gschemas.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-coverflow-alt-tab
+ conflicts = gnome-shell-extension-coverflow-alt-tab
+ source = gnome-shell-extension-coverflow-alt-tab::git+https://github.com/dmo60/CoverflowAltTab.git
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-coverflow-alt-tab-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2a617a2adf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
+# Contributor: XZS <d dot f dot fischer at web dot de>
+# Contributor: Alucryd <alucryd at gmail dot com>
+
+pkgname=gnome-shell-extension-coverflow-alt-tab-git
+pkgver=r104.db5bd2c
+pkgrel=1
+pkgdesc="Alternate Alt-Tab behaviour: iterates through windows in a manner akin to Cover Flow."
+arch=('any')
+url="https://github.com/dmo60/CoverflowAltTab"
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+install=gschemas.install
+source=("${pkgname%-*}::git+https://github.com/dmo60/CoverflowAltTab.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-*}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-*}"
+ msg2 'Locating extension...'
+ cd "$(dirname $(find -name 'metadata.json'))"
+ _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+ msg2 'Installing extension code...'
+ find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "${_destdir}" '{}' +
+ msg2 'Installing schemas...'
+ find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' +
+ msg2 'Installing localization files...'
+ (
+ cd locale
+ for locale in */
+ do
+ install -Dm644 -t "$pkgdir/usr/share/locale/$locale/LC_MESSAGES" "$locale/LC_MESSAGES"/*.mo
+ done
+ )
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..61789e42d2c5
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,20 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+ instructions
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+ instructions
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+}
+
+instructions() {
+ /bin/cat << EOF
+Don't forget to restart GNOME Shell ([Alt]+[F2], r) and to enable extension
+with gnome-tweak-tool.
+EOF
+}