summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 13:59:03 +0100
committerXZS2016-11-01 13:59:03 +0100
commit81182508a452d1a4de1d2dbc6d6e1e2b60b467e0 (patch)
tree00efa40095643a7af880a9d994f56bf422ac6837
parentb17b39e2e377337c3ae2357258ac134e7a562b62 (diff)
downloadaur-81182508a452d1a4de1d2dbc6d6e1e2b60b467e0.tar.gz
choose newest extension source
Some extensions authors introduce build steps required before installing. Their execution normally produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30de4a850bf8..ef698aceec00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,7 +35,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}