diff options
author | XZS | 2022-09-07 21:41:46 +0200 |
---|---|---|
committer | XZS | 2022-09-08 17:59:39 +0200 |
commit | ca0a095011b959a2fe76a5e04c6708a6bd9c03a3 (patch) | |
tree | 456ffefe56cb47f77fe825b167c70b7f352ba33c | |
parent | 7df60a163793d95564cbef3474ba551ff454a622 (diff) | |
download | aur-ca0a095011b959a2fe76a5e04c6708a6bd9c03a3.tar.gz |
exempt gnome-shell from FakeRoot
Certain versions of the gnome-shell binary refuse to run as root, only
outputting an error message. Not even the --version option is parsed.
As the package function runs under FakeRoot, it looks exactly like that
to the program. FakeRoot works by modifying the LD_LIBRARY_PATH and
LD_PRELOAD. By clearing the library to preload, usual function is
restored.
This can be reasonably be considered safe, as the program is only run
with a parameter to output its version number and exit, not making any
modification or communications to or with the rest of the system.
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 5 |
2 files changed, 4 insertions, 3 deletions
@@ -2,7 +2,7 @@ pkgbase = gnome-shell-extension-coverflow-alt-tab-git pkgdesc = Replacement of Alt-Tab, iterates through windows in a cover-flow manner url = https://github.com/dmo60/CoverflowAltTab pkgver = 1.10 - pkgrel = 1 + pkgrel = 2 install = gschemas.install arch = any license = GPL @@ -6,7 +6,7 @@ pkgname=gnome-shell-extension-coverflow-alt-tab-git pkgver=1.10 -pkgrel=1 +pkgrel=2 pkgdesc="Replacement of Alt-Tab, iterates through windows in a cover-flow manner" arch=('any') url="https://github.com/dmo60/CoverflowAltTab" @@ -80,7 +80,8 @@ package_20_version() { local min="${compatibles[0]}" depends+=("gnome-shell>=$(prefix "${min%%.*}")3.$min") if [ "${compatibles[-1]}" != $( - gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+' + LD_PRELOAD= gnome-shell --version | \ + grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+' ) ]; then let max=${compatibles[-1]%%.*}+1 depends+=("gnome-shell<$(prefix "$max")3.$max") |