summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2021-11-02 16:38:59 +0000
committerLeonidas Spyropoulos2021-11-02 16:38:59 +0000
commita64eb87746aaee2d9561321a2f960a6d45076acc (patch)
treea7e5e2478ac6a023cc3509bdf1dcab7ccc8c8b1b
parent8f0407c16c5e7cd78d554e645dc76deb36db32aa (diff)
downloadaur-a64eb87746aaee2d9561321a2f960a6d45076acc.tar.gz
upgpkg: gnome-shell-extension-cpufreq 49.0-2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a69640857384..4b9d4a804dc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = gnome-shell-extension-cpufreq
pkgdesc = Gnome Shell CPU Frequency Monitor and Governor Manager.
pkgver = 49.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/konkor/cpufreq
arch = any
license = GPL3
depends = gnome-shell
conflicts = gnome-shell-extension-cpufreq-git
- source = https://github.com/konkor/cpufreq/archive/v49.0.tar.gz
+ source = -49.0.tar.gz::https://github.com/konkor/cpufreq/archive/v49.0.tar.gz
b2sums = 05844f66a9b808a058ae6b51d67c9bea66e3500736a02fa25cd7e340ba57f14f66eea71918c05396cd5586c04012af2a8393aa24d63519b82555625ef915009b
pkgname = gnome-shell-extension-cpufreq
-
diff --git a/PKGBUILD b/PKGBUILD
index aed8a7ef37b9..cc3baea18aea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Leonidas Spyropoulos <artafinde AT gmail DOT com>
pkgname=gnome-shell-extension-cpufreq
-_pkgname=cpufreq
+_pkgname=${pkgname#gnome-shell-extension-}
pkgver=49.0
-pkgrel=1
+pkgrel=2
pkgdesc="Gnome Shell CPU Frequency Monitor and Governor Manager."
arch=('any')
url="https://github.com/konkor/cpufreq"
license=('GPL3')
conflicts=('gnome-shell-extension-cpufreq-git')
depends=('gnome-shell')
-source=("${url}/archive/v${pkgver}.tar.gz")
+source=("${pkgbase}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
b2sums=('05844f66a9b808a058ae6b51d67c9bea66e3500736a02fa25cd7e340ba57f14f66eea71918c05396cd5586c04012af2a8393aa24d63519b82555625ef915009b')
package() {
_extid='cpufreq@konkor'
- mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/"
+ install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions/"
mv "${_pkgname}-${pkgver}" "${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
}