summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-09-29 10:55:38 -0400
committerTony Lambiris2021-09-29 10:55:38 -0400
commit6762827323b2d908b43403416ff11dd37a2efefc (patch)
treeca281df0801daf1e35a13336084b219bfa72d52c
parent569db9a53c5a93a588c6709eb99fd61e122161c6 (diff)
downloadaur-6762827323b2d908b43403416ff11dd37a2efefc.tar.gz
Version bump
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD71
2 files changed, 31 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index deb7954c3da8..440501544f09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-cpupower-git
pkgdesc = Gnome-Shell Extension for intel-pstate driver
- pkgver = v9.0.4.r14.ga54fcb2
+ pkgver = v9.0.4.r46.gb1eb467
pkgrel = 1
url = https://github.com/martin31821/cpupower.git
install = cpupower.install
diff --git a/PKGBUILD b/PKGBUILD
index 63a1ac772872..d2711001792f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=gnome-shell-extension-cpupower-git
-pkgver=v9.0.4.r14.ga54fcb2
+pkgver=v9.0.4.r46.gb1eb467
pkgrel=1
pkgdesc="Gnome-Shell Extension for intel-pstate driver"
arch=('any')
@@ -9,7 +9,7 @@ url="https://github.com/martin31821/cpupower.git"
license=('GPL3')
depends=('gnome-shell' 'polkit')
makedepends=('git' 'zip' 'unzip')
-install='cpupower.install'
+install=cpupower.install
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
@@ -32,46 +32,35 @@ build() {
make build
}
-
package() {
cd "${srcdir}/${pkgname}"
- make PREFIX="${pkgdir}/usr" install install-tool
- find "${pkgdir}/usr" -type f -exec sed -i -e "s|$pkgdir||g" "{}" \;
-}
+ EXTPATH="${pkgdir}/usr/share/gnome-shell/extensions/cpupower@mko-sl.de"
+ install -dm755 "${EXTPATH}"
+ cp -av * "${EXTPATH}"
+
+ # install cpufreqctl tool to /usr/bin/cpufreqctl
+ install -Dm555 "tool/cpufreqctl" "${pkgdir}/usr/bin/cpufreqctl"
+
+ # polkit policy file, authorizes /usr/bin/cpufreqctl to run
+ POLICYDIR="${pkgdir}/usr/share/polkit-1/actions"
+ POLICYFILE="mko.cpupower.setcpufreq.policy"
+ install -dm755 "${POLICYDIR}"
+ install -Dm644 "data/mko.cpupower.policy.in" "${POLICYDIR}/${POLICYFILE}"
-#package() {
-# cd $_gitname
-#
-# # building/installation
-# make build
-#
-# EXTPATH="${pkgdir}/usr/share/gnome-shell/extensions/cpupower@mko-sl.de"
-# install -dm755 "${EXTPATH}"
-# cp -a * "${EXTPATH}"
-#
-# # install cpufreqctl tool to /usr/bin/cpufreqctl
-# install -Dm555 "tool/cpufreqctl" "${pkgdir}/usr/bin/cpufreqctl"
-#
-# # polkit policy file, authorizes /usr/bin/cpufreqctl to run
-# POLICYDIR="${pkgdir}/usr/share/polkit-1/actions"
-# POLICYFILE="mko.cpupower.setcpufreq.policy"
-# install -dm755 "${POLICYDIR}"
-# install -Dm644 "data/mko.cpupower.policy.in" "${POLICYDIR}/${POLICYFILE}"
-#
-# # polkit rules file, handles policy requests
-# RULESDIR="${pkgdir}/usr/share/polkit-1/rules.d"
-# RULESFILE="10-mko.cpupower.setcpufreq.rules"
-# install -dm750 "${RULESDIR}"
-# install -Dm644 "data/${RULESFILE}" "${RULESDIR}/${RULESFILE}"
-#
-# # gsettings xml schema file
-# SCHEMADIR="${pkgdir}/usr/share/glib-2.0/schemas"
-# SCHEMAFILE="org.gnome.shell.extensions.cpupower.gschema.xml"
-# install -dm755 "${SCHEMADIR}"
-# install -Dm644 "schemas/${SCHEMAFILE}" "${SCHEMADIR}/${SCHEMAFILE}"
-#
-# # update policy to reflect cpufreqctl path
-# sed -i -e 's:{{PATH}}:/usr/bin/cpufreqctl:g' \
-# -e 's:{{ID}}:mko.cpupower.setcpufreq:g' "${POLICYDIR}/${POLICYFILE}"
-#}
+ # polkit rules file, handles policy requests
+ RULESDIR="${pkgdir}/usr/share/polkit-1/rules.d"
+ RULESFILE="10-mko.cpupower.setcpufreq.rules"
+ install -dm750 "${RULESDIR}"
+ install -Dm644 "data/${RULESFILE}" "${RULESDIR}/${RULESFILE}"
+
+ # gsettings xml schema file
+ SCHEMADIR="${pkgdir}/usr/share/glib-2.0/schemas"
+ SCHEMAFILE="org.gnome.shell.extensions.cpupower.gschema.xml"
+ install -dm755 "${SCHEMADIR}"
+ install -Dm644 "schemas/${SCHEMAFILE}" "${SCHEMADIR}/${SCHEMAFILE}"
+
+ # update policy to reflect cpufreqctl path
+ sed -i -e 's:{{PATH}}:/usr/bin/cpufreqctl:g' \
+ -e 's:{{ID}}:mko.cpupower.setcpufreq:g' "${POLICYDIR}/${POLICYFILE}"
+}