summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-03-06 14:46:57 -0500
committerTony Lambiris2017-03-06 14:46:57 -0500
commitfb69c1a076bee631f58d2cd816683c01a79b84dd (patch)
tree93d9d40aa057a1e1e7f0984c5c9a35ed6b2650bb
downloadaur-fb69c1a076bee631f58d2cd816683c01a79b84dd.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c9741b96d89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-cpupower-git
+ pkgdesc = Gnome-Shell Extension for intel-pstate driver
+ pkgver = 64.81d06c7
+ pkgrel = 1
+ url = https://github.com/martin31821/cpupower
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ source = git+https://github.com/martin31821/cpupower.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-cpupower-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9210cc3b80da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=gnome-shell-extension-cpupower-git
+_gitname=cpupower
+pkgver=64.81d06c7
+pkgrel=1
+pkgdesc="Gnome-Shell Extension for intel-pstate driver"
+arch=('any')
+url="https://github.com/martin31821/cpupower"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+source=('git+https://github.com/martin31821/cpupower.git')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd $_gitname
+ _extid="cpupower@mko-sl.de"
+ _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
+
+ install -dm755 "${_extpath}"
+ cp -r * "${_extpath}"
+}
+md5sums=('SKIP')