summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2015-12-06 21:06:44 +0100
committerXZS2015-12-08 18:12:05 +0100
commitb65b6b9974ab974e253a25ae821bc3ee7e759fcd (patch)
tree71b7f5f352f5d91d255c3af960e686a2399a7a2b
parentccf702f14fdf29dadbbf530c6149d482ef4c5c90 (diff)
downloadaur-b65b6b9974ab974e253a25ae821bc3ee7e759fcd.tar.gz
patch up unreadable image
Due to a bug with librsvg[1] GTK is unable to process the image logo.svg. As ImageMagic still can handle it without any hiccups, it can be converted to a PNG before GTK ever sees it until the bug is fixed. [1]: https://bugs.archlinux.org/index.php?do=details&task_id=47245
-rw-r--r--PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d90eebdb4ba..12e837741b83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Carl George < arch at cgtx dot us >
+# Contributor: XZS < d dot f dot fischer at web dot de >
# Contributor: Janne Haapsaari < haaja at iki dot fi >
# Contributor: Christopher Krooß < didi2002 at web dot de >
@@ -21,6 +22,15 @@ source=("https://github.com/${_author}/${_extname}/archive/extensions.gnome.org-
noextract=()
sha256sums=('50bd242f3f6e6089137957c175462475d10a2e39f6014184b792248ed7708084')
+prepare() {
+ cd "${srcdir}/${_extname}-extensions.gnome.org-v${pkgver}"
+ grep -lZr logo.svg | while IFS= read -rd $'\0' file
+ do
+ sed -i 's/\(logo\.\)svg/\1png/' "$file"
+ done
+ convert media/logo.{svg,png}
+}
+
build() {
cd "${srcdir}/${_extname}-extensions.gnome.org-v${pkgver}"
make