summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:51:55 +0200
committerXZS2016-04-22 11:51:55 +0200
commit3de65bd19e4c73fc57ac1c43d8c0e07f3dde424c (patch)
tree7033fc9d8ec1498ea4ad04c3de1d13604e93afd4
parent94dbeaebcb9e2c4a6fd808abf55494865157c540 (diff)
downloadaur-3de65bd19e4c73fc57ac1c43d8c0e07f3dde424c.tar.gz
fix version comparison
Comparing the minor version to a string of minor and major will never succeed. Originally, a restriction on the current shell version was omitted for historical reasons - most packages did so when dependencies were defined manually. This now turns into a concious decision to - permit the usage of the extension in instable gnome-shell versions - the ones with odd minor version numbers - where incompatibilities are introduced gradually. - ease the transition from one stable gnome-shell version - the ones with even minor version numbers - to the next. In an ideal world, all extensions should have been updates before the update hits the repositories. But as Arch is quite more on the edge than developers of some of the extensions, this is not the case more often than not.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9c93a9f4008..3bd637f976c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = gnome-shell-extension-dash-to-dock-git
makedepends = git
depends = dconf
depends = gnome-shell
- provides = gnome-shell-extension-dash-to-dock=53.r0.g1452801
+ provides = gnome-shell-extension-dash-to-dock=53
conflicts = gnome-shell-extension-dash-to-dock
source = gnome-shell-extension-dash-to-dock::git+https://github.com/micheleg/dash-to-dock/
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 165386357485..429197ec996c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -84,7 +84,7 @@ package_20_version() {
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"
- if [ "3.$max" != $(
+ if [ "$max" != $(
gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
) ]; then
depends+=("gnome-shell<3.$((${max%%.*} + 1))")