summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 13:56:43 +0100
committerXZS2016-11-02 18:15:50 +0100
commit83af4cec04083d8fa77b13f4b24446f9838b9880 (patch)
treef27fcc2c07014e3c2e7cceff796bb2f816b3a5d6
parent137f06657eab056a79c2c57858387af394512b31 (diff)
downloadaur-83af4cec04083d8fa77b13f4b24446f9838b9880.tar.gz
choose newest extension source
This extension requires a build step before installation. Its execution produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1494dcff7df6..baba20c9da0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-dash-to-dock-git
pkgdesc = move the dash out of the overview transforming it in a dock
pkgver = 55
- pkgrel = 1
+ pkgrel = 2
url = https://micheleg.github.io/dash-to-dock/
install = gschemas.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 3c53f76f6ade..5db7aa084a28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gnome-shell-extension-dash-to-dock-git
pkgver=55
-pkgrel=1
+pkgrel=2
pkgdesc="move the dash out of the overview transforming it in a dock"
arch=('any')
url="https://micheleg.github.io/dash-to-dock/"
@@ -45,7 +45,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}