summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmin Vakil2021-07-30 02:14:11 +0430
committerAmin Vakil2021-07-30 02:17:30 +0430
commit890e5bfb373ace8e335a12e5527915af99f0d533 (patch)
tree4dfb357e35fe3a289a8b46a25daf1487abbc7000
parent22c51b36fb29b00398e36469c8383d16e9804c4d (diff)
downloadaur-890e5bfb373ace8e335a12e5527915af99f0d533.tar.gz
Use gnome 40 PR branch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca3eb23a2c4c..5e89b3167cec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-dash-to-dock-git
pkgdesc = move the dash out of the overview transforming it in a dock
- pkgver = 69.r13.ga081e41
+ pkgver = 69.r14.g302c693
pkgrel = 1
url = https://micheleg.github.io/dash-to-dock/
arch = any
@@ -11,7 +11,8 @@ pkgbase = gnome-shell-extension-dash-to-dock-git
provides = gnome-shell-extension-dash-to-dock
conflicts = gnome-shell-extension-dash-to-dock
source = git+https://github.com/micheleg/dash-to-dock.git
+ source = https://patch-diff.githubusercontent.com/raw/micheleg/dash-to-dock/pull/1402.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = gnome-shell-extension-dash-to-dock-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1925f4f535fc..7116014b5434 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_srcname=dash-to-dock
pkgname=gnome-shell-extension-dash-to-dock-git
-pkgver=69.r13.ga081e41
+pkgver=69.r14.g302c693
pkgrel=1
pkgdesc="move the dash out of the overview transforming it in a dock"
arch=('any')
@@ -17,8 +17,10 @@ depends=('gnome-shell')
makedepends=('git' 'sassc')
conflicts=('gnome-shell-extension-dash-to-dock')
provides=('gnome-shell-extension-dash-to-dock')
-source=("git+https://github.com/micheleg/${_srcname}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/micheleg/${_srcname}.git"
+ "https://patch-diff.githubusercontent.com/raw/micheleg/${_srcname}/pull/1402.patch")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${_srcname}"
@@ -27,6 +29,10 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ patch -d "${_srcname}" -p1 -i ../1402.patch
+}
+
build() {
export SASS=sassc
cd "${_srcname}"