summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2019-02-24 22:45:35 +0000
committergrufo2019-02-24 22:45:35 +0000
commit12d41e3eee6d7332ef495969df49f3e075f04aeb (patch)
treebec89bc89e1e6b83f108c26c2445ae0c4100a1c0
parent2ad987fc0cb266613ae61205fcf02e85df6bcef4 (diff)
downloadaur-12d41e3eee6d7332ef495969df49f3e075f04aeb.tar.gz
Added localization (thanks to Massimo Branchini)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e4bf7fadde9..cb89fdbebd03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = gnome-shell-extension-desktop-icons
pkgdesc = Add icons to the desktop
- pkgver = r237.d886ac7
+ pkgver = r369.c0d5866
pkgrel = 1
url = https://extensions.gnome.org/extension/1465/desktop-icons/
arch = x86_64
arch = i686
license = GPL3
makedepends = git
+ makedepends = meson
+ makedepends = glib2
depends = gnome-shell
options = !strip
source = git+https://gitlab.gnome.org/World/ShellExtensions/desktop-icons.git
diff --git a/PKGBUILD b/PKGBUILD
index 5db4d9374c17..a62e74722aac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: grufo <madmurphy333 AT gmail DOT com>
# Contributor: somepaulo <burafino AT gmail DOT com>
+# Contributor: Massimo Branchini <max.bra.gtalk AT gmail DOT com>
_extname='desktop-icons'
_uuid="${_extname}@csoriano"
+
pkgname="gnome-shell-extension-${_extname}"
-pkgver='r237.d886ac7'
+pkgver='r369.c0d5866'
pkgrel=1
pkgdesc='Add icons to the desktop'
arch=('x86_64' 'i686')
url="https://extensions.gnome.org/extension/1465/${_extname}/"
license=('GPL3')
depends=('gnome-shell')
-makedepends=('git')
+makedepends=('git' 'meson' 'glib2')
options=('!strip')
source=("git+https://gitlab.gnome.org/World/ShellExtensions/${_extname}.git")
md5sums=('SKIP')
@@ -25,10 +27,25 @@ pkgver() {
package() {
- cd "${srcdir}/${_extname}"
-
install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
- cp -r "${srcdir}/${_extname}"/* "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+
+ # taken from export-zip.sh
+ local _repodir="${srcdir}/${_extname}"
+ local _build_dir="${_repodir}/builddir"
+ local _local_prefix="${_repodir}/${_uuid}"
+ local _extension_dir="${_local_prefix}/share/gnome-shell/extensions/${_uuid}"
+ local _schemadir="${_local_prefix}/share/glib-2.0/schemas"
+
+ meson --prefix="${_local_prefix}" --localedir=locale "${_build_dir}" "${_repodir}"
+ ninja -C "${_build_dir}" install
+
+ cd "${_local_prefix}"
+ mkdir schemas
+ cp "${_schemadir}"/*.xml schemas/
+ glib-compile-schemas schemas/
+ cp -r "${_extension_dir}"/* .
+
+ cp -dpr --no-preserve=ownership {*.js,*.css,*.json,locale,schemas} "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
}