summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-10-18 20:18:10 +0900
committerhayao2020-10-18 20:18:10 +0900
commit167d338d3f298ad01d3bf5815979799d33cb192c (patch)
tree1ec9d2370114332bc5cb3f3573ec5246f5748814
parent19916eff1d2417e46977bb43bbc5ef27730c8c3a (diff)
downloadaur-167d338d3f298ad01d3bf5815979799d33cb192c.tar.gz
[update] : Updated 0.14.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD52
2 files changed, 44 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2e9d519dedd..da1794188fd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-desktop-icons-ng
pkgdesc = A fork from the official desktop icons project, with several enhancements like Drag'n'Drop.
- pkgver = 0.13.0
+ pkgver = 0.14.0
pkgrel = 1
url = https://extensions.gnome.org/extension/2087/desktop-icons-ng-ding/
arch = x86_64
@@ -11,8 +11,9 @@ pkgbase = gnome-shell-extension-desktop-icons-ng
makedepends = glib2
depends = gnome-shell
conflicts = gnome-shell-extension-desktop-icons-ng-git
- source = https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/13/desktop-icons-ng-0.13.0.tar.gz
- sha256sums = SKIP
+ source = desktop-icons-ng-0.14.0.tar.gz::https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/0.14.0/desktop-icons-ng-0.14.0.tar.gz
+ sha256sums = 6ebc6a66000900fb56128bd16b66578e22c4f3263dd3ad382c6450b495ec2572
+ sha512sums = feb3197f8f431cc35726ddbc64d8b5672886d75579db1b3a27eaf8e7326d0a626bb29227d24a01f6d6f548c2c52537a8a6ae0d0889aa00c928d7132ac1a924ad
pkgname = gnome-shell-extension-desktop-icons-ng
diff --git a/PKGBUILD b/PKGBUILD
index 81a3d2ee712c..4fcf77af7f33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Yamada Hayao <hayao@fascode.net>
-_extname='desktop-icons-ng'
-
-_uuid="ding@rastersoft.com"
+# Change this value if you want to lower the version.
+_pkgver="14"
+#_pkgver="13"
+_extname='desktop-icons-ng'
pkgname="gnome-shell-extension-${_extname}"
-_pkgver="13"
+_uuid="ding@rastersoft.com"
pkgver="0.${_pkgver}.0"
-
+_latest="14"
pkgrel=1
pkgdesc="A fork from the official desktop icons project, with several enhancements like Drag'n'Drop."
arch=('x86_64' 'i686')
@@ -16,8 +17,35 @@ license=('GPL3')
depends=('gnome-shell')
makedepends=('git' 'meson' 'glib2')
conflicts=("${pkgname}-git")
-source=("https://gitlab.com/rastersoft/${_extname}/-/archive/${_pkgver}/${_extname}-${pkgver}.tar.gz")
-sha256sums=('SKIP')
+if [[ "${pkgver}" = "0.13.0" ]]; then
+ source+=(
+ "${_extname}-${pkgver}.tar.gz::https://gitlab.com/rastersoft/${_extname}/-/archive/${_pkgver}/${_extname}-${_pkgver}.tar.gz"
+ #"${_extname}-${pkgver}.tar.gz::https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/13/desktop-icons-ng-13.tar.gz"
+ )
+ sha256sums+=("SKIP")
+ sha512sums+=("SKIP")
+elif [[ "${_pkgver}" = "${_latest}" ]]; then
+ source+=(
+ "${_extname}-${pkgver}.tar.gz::https://gitlab.com/rastersoft/${_extname}/-/archive/${pkgver}/${_extname}-${pkgver}.tar.gz"
+ #${_extname}-${pkgver}.tar.gz::"https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/0.14.0/desktop-icons-ng-0.14.0.tar.gz"
+ )
+ sha256sums+=(
+ # desktop-icons-ng-0.14.0.tar.gz
+ '6ebc6a66000900fb56128bd16b66578e22c4f3263dd3ad382c6450b495ec2572'
+ )
+ sha512sums+=(
+ # desktop-icons-ng-0.14.0.tar.gz
+ 'feb3197f8f431cc35726ddbc64d8b5672886d75579db1b3a27eaf8e7326d0a626bb29227d24a01f6d6f548c2c52537a8a6ae0d0889aa00c928d7132ac1a924ad'
+ )
+else
+ source+=(
+ "https://gitlab.com/rastersoft/${_extname}/-/archive/${pkgver}/${_extname}-${pkgver}.tar.gz"
+ #"https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/0.14.0/desktop-icons-ng-0.14.0.tar.gz"
+ )
+ sha256sums+=("SKIP")
+ sha512sums+=("SKIP")
+fi
+
package() {
@@ -25,12 +53,12 @@ package() {
install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
-
- # Prepare _repodir
- mv "$( ls "${srcdir}" | grep "${_extname}-${_pkgver}" )" "${srcdir}/${_extname}-${pkgver}"
-
# taken from export-zip.sh
- local _repodir="${srcdir}/${_extname}-${pkgver}"
+ if [[ -d "${_extname}-${_pkgver}" ]]; then
+ local _repodir="${srcdir}/${_extname}-${_pkgver}"
+ else
+ local _repodir="${srcdir}/${_extname}-${pkgver}"
+ fi
local _build_dir="${_repodir}/builddir"
local _local_prefix="${_repodir}/${_uuid}"
local _extension_dir="${_local_prefix}/share/gnome-shell/extensions/${_uuid}"