summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-08-17 10:32:57 +0900
committerhayao2020-08-17 10:32:57 +0900
commitf2b382dbd42077df6c385eba1d356c0bd90c8284 (patch)
treeab28819de8a0069111159dae4c4e2177a8950e49
downloadaur-f2b382dbd42077df6c385eba1d356c0bd90c8284.tar.gz
[add] : Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffcb087a3e36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-shell-extension-desktop-icons-ng
+ pkgdesc = A fork from the official desktop icons project, with several enhancements like Drag'n'Drop.
+ pkgver = 0.12.0
+ pkgrel = 1
+ url = https://extensions.gnome.org/extension/2087/desktop-icons-ng-ding/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = glib2
+ depends = gnome-shell
+ conflicts = gnome-shell-extension-desktop-icons-ng-git
+ source = https://gitlab.com/rastersoft/desktop-icons-ng/-/archive/0.12.0/desktop-icons-ng-0.12.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-desktop-icons-ng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..765df0c6e951
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Yamada Hayao <hayao@fascode.net>
+
+_extname='desktop-icons-ng'
+
+_uuid="ding@rastersoft.com"
+
+pkgname="gnome-shell-extension-${_extname}"
+pkgver='0.12.0'
+pkgrel=1
+pkgdesc="A fork from the official desktop icons project, with several enhancements like Drag'n'Drop."
+arch=('x86_64' 'i686')
+url="https://extensions.gnome.org/extension/2087/desktop-icons-ng-ding/"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git' 'meson' 'glib2')
+conflicts=("${pkgname}-git")
+source=("https://gitlab.com/rastersoft/${_extname}/-/archive/${pkgver}/${_extname}-${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+
+ cd "${srcdir}"
+
+ install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+
+ # taken from export-zip.sh
+ local _repodir="${srcdir}/${_extname}-${pkgver}"
+ local _build_dir="${_repodir}/builddir"
+ local _local_prefix="${_repodir}/${_uuid}"
+ local _extension_dir="${_local_prefix}/share/gnome-shell/extensions/${_uuid}"
+ local _schemadir="${_local_prefix}/share/glib-2.0/schemas"
+
+ meson --prefix="${_local_prefix}" --localedir=locale "${_build_dir}" "${_repodir}"
+ ninja -C "${_build_dir}" install
+
+ cd "${_local_prefix}"
+ mkdir schemas
+ cp "${_schemadir}"/*.xml schemas/
+ glib-compile-schemas schemas/
+ cp -r "${_extension_dir}"/* .
+
+ cp -dpr --no-preserve=ownership {*.js,*.css,*.json,locale,schemas} "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+
+}