summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSte742018-07-05 20:03:18 +0200
committerSte742018-07-05 20:03:18 +0200
commit3289ac82f618f48baaeac2e0d0b5c60d5dd5b66a (patch)
tree94788cd4b794b414cbba2fed5051da25232ae4fd
parentb921fd7f793a51dece0b96581223363e9dc6e91d (diff)
downloadaur-3289ac82f618f48baaeac2e0d0b5c60d5dd5b66a.tar.gz
Update to v0.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD23
2 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 967b288be392..c2f961ae7672 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = gnome-shell-extension-desktop-icons-reworked
pkgdesc = Add icons to the desktop
- pkgver = 0.2
- pkgrel = 2
+ pkgver = 0.4
+ pkgrel = 1
url = https://github.com/Ste74/org.gnome.desktop-icons-reworked
arch = any
license = LGPL3
- makedepends = cmake
depends = gnome-shell
depends = gnome-shell-extensions
conflicts = gnome-shell-extension-desktop-icons
options = !strip
- source = https://github.com/Ste74/org.gnome.desktop-icons-reworked/archive/7512f35108c2c462310bf9c7f8e4a4580c1ae748.tar.gz
- sha512sums = 593b919f8e84c28da5b303b1b91f282b5fcdc143a4547f46ef81029abc226ad0a16349b8ff603c0d71e9b6d1f8da9a838d6aa5a44caeead080440ed805ea98e4
+ source = https://github.com/Ste74/org.gnome.desktop-icons-reworked/archive/v0.4.tar.gz
+ sha512sums = ede5f3123e3a413ba8ddbaa2dda24df8934347cd61e8c992d4df2932ca26551f9aa7bb6238ca0752931409e06f7a4e5cf7433462be41005a0eaecb817dfd56ab
pkgname = gnome-shell-extension-desktop-icons-reworked
diff --git a/PKGBUILD b/PKGBUILD
index 8d1ef3670c8a..8697df65817a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,23 @@
# Maintainer: Stefano Capitani <stefano@manjaro.org>
+# Contributor: dady8889 <https://github.com/dady8889>
_pkgbase=gnome-shell-extension-desktop-icons
pkgname=$_pkgbase-reworked
-pkgver=0.2
-pkgrel=2
-_commit=7512f35108c2c462310bf9c7f8e4a4580c1ae748
+pkgver=0.4
+pkgrel=1
+#_commit=7512f35108c2c462310bf9c7f8e4a4580c1ae748
_ext_dir=org.gnome.desktop-icons-reworked
pkgdesc="Add icons to the desktop"
arch=('any')
url="https://github.com/Ste74/$_ext_dir"
license=("LGPL3")
depends=('gnome-shell' 'gnome-shell-extensions')
-makedepends=('cmake')
conflicts=("$_pkgbase")
options=('!strip')
-source=("$url/archive/$_commit.tar.gz")
-sha512sums=('593b919f8e84c28da5b303b1b91f282b5fcdc143a4547f46ef81029abc226ad0a16349b8ff603c0d71e9b6d1f8da9a838d6aa5a44caeead080440ed805ea98e4')
-
-build() {
- mkdir -p $_ext_dir-$_commit/build
- cd $_ext_dir-$_commit/build
- cmake ../
- make
-}
+source=("$url/archive/v$pkgver.tar.gz")
+sha512sums=('ede5f3123e3a413ba8ddbaa2dda24df8934347cd61e8c992d4df2932ca26551f9aa7bb6238ca0752931409e06f7a4e5cf7433462be41005a0eaecb817dfd56ab')
package() {
- cd $_ext_dir-$_commit/build
- make DESTDIR="${pkgdir}" install
+ cd $_ext_dir-$pkgver
+ make DESTDIR="${pkgdir}" INSTALL="system" install
}