aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Diovani2019-07-09 14:30:28 -0300
committerPaulo Diovani2019-07-09 15:01:37 -0300
commitd9452c2a5f90aa970cd65377ad755a203c1808f1 (patch)
treec8cb5c91644b41d278decf1f9d16c4968f046b9c
downloadaur-d9452c2a5f90aa970cd65377ad755a203c1808f1.tar.gz
Create AUR package
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd670319a7f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-disable-workspace-switcher-popup-git
+ pkgdesc = Gnome Shell 3 extension that disables the arrow displayed during workspace switching.
+ pkgver = 9b4e2bb
+ pkgrel = 1
+ url = https://github.com/windsorschmidt/disable-workspace-switcher-popup
+ arch = any
+ makedepends = git
+ depends = gnome-shell>=3.0.2
+ depends = xorg-xprop
+ provides = gnome-shell-extension-disable-workspace-switcher-popup
+ source = gnome-shell-extension-disable-workspace-switcher-popup-git::git+https://github.com/windsorschmidt/disable-workspace-switcher-popup
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-disable-workspace-switcher-popup-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ce2fba6c7c78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+gnome-shell-extension-disable-workspace-switcher-popup-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06fc045d4e9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Paulo Diovani <paulo AT diovani DOT com>
+
+pkgname=gnome-shell-extension-disable-workspace-switcher-popup-git
+pkgver=9b4e2bb
+pkgrel=1
+pkgdesc="Gnome Shell 3 extension that disables the arrow displayed during workspace switching."
+arch=('any')
+url="https://github.com/windsorschmidt/disable-workspace-switcher-popup"
+depends=('gnome-shell>=3.0.2' 'xorg-xprop')
+makedepends=('git')
+provides=("${pkgname/-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --always
+}
+
+package() {
+ cd "$pkgname"
+ # mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
+ # cp -R "disable-workspace-switcher-popup@github.com" "$pkgdir/usr/share/gnome-shell/extensions"
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/disable-workspace-switcher-popup@github.com"
+ cp extension.js metadata.json "$pkgdir/usr/share/gnome-shell/extensions/disable-workspace-switcher-popup@github.com"
+}