summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-10-01 22:10:06 +0200
committerPhilip Goto2018-10-01 22:10:06 +0200
commit25e5624001f4e58424385c930a5680762c80ab93 (patch)
tree5d2b831bc41a5d6691f251768ec973dc2c34cceb
downloadaur-25e5624001f4e58424385c930a5680762c80ab93.tar.gz
Initialize package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45eacdf69184
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-do-not-disturb-git
+ pkgdesc = Enable or disable do not disturb mode
+ pkgver = r31.93f3ccb
+ pkgrel = 1
+ url = https://github.com/kylecorry31/gnome-shell-extension-do-not-disturb
+ arch = any
+ license = MIT
+ depends = gnome-shell
+ provides = gnome-shell-extension-do-not-disturb
+ conflicts = gnome-shell-extension-do-not-disturb
+ source = git+https://github.com/kylecorry31/gnome-shell-extension-do-not-disturb.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-do-not-disturb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b5d2c4ff47b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=gnome-shell-extension-do-not-disturb-git
+pkgver=r31.93f3ccb
+pkgrel=1
+pkgdesc="Enable or disable do not disturb mode"
+arch=(any)
+url="https://github.com/kylecorry31/gnome-shell-extension-do-not-disturb"
+license=(MIT)
+depends=(gnome-shell)
+provides=(gnome-shell-extension-do-not-disturb)
+conflicts=(gnome-shell-extension-do-not-disturb)
+source=("git+https://github.com/kylecorry31/gnome-shell-extension-do-not-disturb.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd gnome-shell-extension-do-not-disturb
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd gnome-shell-extension-do-not-disturb
+ make
+}
+
+package() {
+ cd gnome-shell-extension-do-not-disturb
+ make DESTDIR="$pkgdir/" install
+}