summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2023-03-27 11:44:19 +0200
committerChristian Schendel2023-03-27 11:44:19 +0200
commitbdd14dd782406d2d1a3d6f930233a69cbed446e7 (patch)
treed975a662ab3695190a59af9baa260e65a441bd5a
parent8799ca3334a086d9d298d046aba08e2d43441273 (diff)
downloadaur-bdd14dd782406d2d1a3d6f930233a69cbed446e7.tar.gz
Cleaning up
removed .install file removed glib2 makedepends removed stripping removed redundant permission switch in install removed gschema directory
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD29
-rw-r--r--gnome-shell-extension-dynamic-calendar-and-clocks-icons.install30
4 files changed, 11 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9882cd406d4..ece5e26ec336 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = gnome-shell-extension-dynamic-calendar-and-clocks-icons-git
pkgdesc = A GNOME shell extension that let Calendar and Clocks icons show current date and time.
- pkgver = r9.e9d7cde
+ pkgver = r15.01ea326
pkgrel = 1
url = https://github.com/fcusr/dynamic-calendar-and-clocks-icons
- install = gnome-shell-extension-dynamic-calendar-and-clocks-icons.install
arch = any
license = GPL3
makedepends = git
- makedepends = glib2
depends = gnome-shell>=1:43
provides = gnome-shell-extension-dynamic-calendar-and-clocks-icons
conflicts = gnome-shell-extension-dynamic-calendar-and-clocks-icons
- options = !strip
source = gnome-shell-extension-dynamic-calendar-and-clocks-icons::git+https://github.com/fcusr/dynamic-calendar-and-clocks-icons.git
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 833085309a2e..b39f3b2a183f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-*.tar.gz
-*.pkg.tar.zst
-*/*
-
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 0b9ee87fd11b..ba0c9aed4b77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: Christian Schendel <doppelhelix@gmail.com>
pkgname=gnome-shell-extension-dynamic-calendar-and-clocks-icons-git
-pkgver=r9.e9d7cde
+pkgver=r15.01ea326
pkgrel=1
pkgdesc="A GNOME shell extension that let Calendar and Clocks icons show current date and time."
arch=('any')
url="https://github.com/fcusr/dynamic-calendar-and-clocks-icons"
-install="${pkgname%-git}.install"
license=('GPL3')
depends=('gnome-shell>=1:43')
-makedepends=('git'
- 'glib2')
+makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-options=('!strip')
source=("${pkgname%-git}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
- # support repositories that start without a tag but get tagged later on
( set -o pipefail
git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -28,28 +24,15 @@ pkgver() {
}
package() {
- # Some extensions use make only to zip. We need to harcode the existing path
- local extension_dir="${srcdir}/${pkgname%-git}/dynamic-calendar-and-clocks-icons@fcusr.github.com"
+ cd "$(dirname $(find -name 'metadata.json' -print -quit))"
- cd "${extension_dir}"
-
- # It's nice to have a well-formed metadata.json but we need to work around some hickups that may occur
local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
- #local schema=$(grep -Po '(?<="settings-schema": ")[^"]*' metadata.json).gschema.xml
local schema=org.gnome.shell.extensions.dynamic-calendar-and-clocks-icons.gschema.xml
local destdir="${pkgdir}/usr/share/gnome-shell/extensions/${uuid}"
- install -dm755 "${destdir}"
- # Don't install unnecessary files
- find . -regextype posix-egrep -regex ".*\.(js|json|xml|png|svg|css|compiled)$" -exec\
- install -Dm 644 {} ${destdir}/{} \;
-
+ install -d "${destdir}"
+ find . -regextype posix-egrep -regex ".*\.(js|json|png|svg|css)$" -exec\
+ install -Dm644 {} ${destdir}/{} \;
install -Dm644 "schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
-
- # rebuild compiled GSettings schemas if missing
- if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
- glib-compile-schemas "${destdir}/schemas"
- fi
}
-
diff --git a/gnome-shell-extension-dynamic-calendar-and-clocks-icons.install b/gnome-shell-extension-dynamic-calendar-and-clocks-icons.install
deleted file mode 100644
index 7f4546e45017..000000000000
--- a/gnome-shell-extension-dynamic-calendar-and-clocks-icons.install
+++ /dev/null
@@ -1,30 +0,0 @@
-post_install() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_install
-}
-
-post_upgrade() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_upgrade
-}
-
-post_remove() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
-}
-
-instructions_install() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r).
-Activate the extension with gnome-tweak-tool.
-
-EOF
-}
-
-instructions_upgrade() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
-
-EOF
-}