summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2018-08-10 19:42:08 -0700
committerLlewelyn Trahaearn2018-08-10 19:42:08 -0700
commit7eb4a2ab19133e4c4943166d4a3c50dec5aa211b (patch)
treec59f30486e4f0ef120291396d37ad603fb39499f
parent09fecfd39c34e2586b2991a4f5b00a00090ea1f5 (diff)
downloadaur-7eb4a2ab19133e4c4943166d4a3c50dec5aa211b.tar.gz
Use relative path for locale.
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e7174366772..45fb5aece3a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,17 +11,17 @@ depends=('gnome-shell')
makedepends=('git')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}" 'gnome-shell-extensions-git')
-source=("${pkgname}::git+${url}")
+source=("${pkgname%-*}::git+${url}")
sha512sums=('SKIP')
_branch=master
prepare() {
- cd "${pkgname}"
+ cd "${pkgname%-*}"
git checkout ${_branch}
}
pkgver() {
- cd "${pkgname}"
+ cd "${pkgname%-*}"
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -37,7 +37,7 @@ package() {
find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' -or -iname '*.gtkbuilder' -or -iname '*.glade' \) -exec install -Dm644 -t "${_destdir}" '{}' +
find -maxdepth 2 \( -iname '*.svg*' \) -exec install -Dm644 -t "${_destdir}/images" '{}' +
find -name '*.xml' -exec install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas" '{}' +
- cd "${srcdir}/${pkgname}/locale"
+ cd locale
for locale in */
do
install -Dm644 -t "${pkgdir}/usr/share/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo