summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2015-08-05 09:25:43 -0700
committerLlewelyn Trahaearn2015-08-05 09:25:43 -0700
commit92b548ba5280beb0476fc7578207ab28d9fdabde (patch)
tree17091a28ab393e591c4d2a65e65d16f576ad4c89
downloadaur-92b548ba5280beb0476fc7578207ab28d9fdabde.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
-rw-r--r--gschemas.install19
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6baeacbebc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-easyscreencast-git
+ pkgdesc = Provides a convienent top bar pull-down interface to configure the GNOME Shell Screencast Recording feature.
+ pkgver = 0.9.7.1.r4.gef69b61
+ pkgrel = 2
+ url = https://github.com/iacopodeenosee/EasyScreenCast
+ install = gschemas.install
+ arch = any
+ license = GPL3
+ depends = gnome-shell
+ provides = gnome-shell-extension-easyscreencast
+ conflicts = gnome-shell-extensions-git
+ conflicts = gnome-shell-extensions-easyscreencast
+ source = gnome-shell-extension-easyscreencast-git::git+https://github.com/iacopodeenosee/EasyScreenCast.git
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-easyscreencast-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17b954cdbadc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
+
+pkgname="gnome-shell-extension-easyscreencast-git"
+pkgver=0.9.7.1.r4.gef69b61
+pkgrel=2
+pkgdesc="Provides a convienent top bar pull-down interface to configure the GNOME Shell Screencast Recording feature."
+arch=('any')
+url="https://github.com/iacopodeenosee/EasyScreenCast"
+license=('GPL3')
+depends=('gnome-shell')
+provides=('gnome-shell-extension-easyscreencast')
+conflicts=('gnome-shell-extensions-git' 'gnome-shell-extensions-easyscreencast')
+install="gschemas.install"
+source=("${pkgname}::git+https://github.com/iacopodeenosee/EasyScreenCast.git")
+sha512sums=('SKIP')
+_branch=master
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git checkout ${_branch} --quiet
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout ${_branch}
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ # Locate the extension.
+ _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+ # Copy extension files into place.
+ find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' -or -iname '*.gtkbuilder' \) -exec install -Dm644 -t "${_destdir}" '{}' +
+ find -maxdepth 2 \( -iname '*.svg*' \) -exec install -Dm644 -t "${_destdir}/images" '{}' +
+ find -maxdepth 2 \( -wholename '*schemas/*' \) -exec install -Dm644 -t "${_destdir}/schemas" '{}' +
+ cd "${srcdir}/${pkgname}/locale"
+ for locale in */
+ do
+ install -Dm644 -t "${_destdir}/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
+ done
+ cd "${srcdir}/${pkgname}/locale-UI"
+ for locale in */
+ do
+ install -Dm644 -t "${_destdir}/locale-UI/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
+ done
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..5d7550488b1d
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,19 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+ instructions
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+instructions() {
+ /bin/cat << EOF
+Don't forget to restart GNOME Shell ([Alt]+[F2], r) and to enable extension
+with gnome-tweak-tool.
+EOF
+}