summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-09-16 09:38:35 -0700
committerLlewelyn Trahaearn2016-09-16 09:38:35 -0700
commite86ae61607653aa1062650edac183a6124a9ef88 (patch)
treeaa9e1b87253baa6be67b5430e042807555ab4f8d
parent547f64957ad5561315e5e7230dbfb35317436d06 (diff)
downloadaur-e86ae61607653aa1062650edac183a6124a9ef88.tar.gz
Function order revised to reflect changes to their order of execution by makepkg. Include a remote sync in prepare to update assets during dirty builds.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d8039580813..f510cb7a1ef6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jul 12 05:02:18 UTC 2016
+# Fri Sep 16 16:33:01 UTC 2016
pkgbase = gnome-shell-extension-easyscreencast-git
pkgdesc = Provides a convienent top bar pop-down interface to configure the GNOME Shell Screencast Recording feature.
- pkgver = 0.9.8.5.r0.g7e4d50e
+ pkgver = 0.9.8.5.r11.g3b751d9
pkgrel = 1
url = https://github.com/iacopodeenosee/EasyScreenCast
install = gschemas.install
diff --git a/PKGBUILD b/PKGBUILD
index fbf992a27632..d3b05f2d6a95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
pkgname="gnome-shell-extension-easyscreencast-git"
-pkgver=0.9.8.5.r0.g7e4d50e
+pkgver=0.9.8.5.r11.g3b751d9
pkgrel=1
pkgdesc="Provides a convienent top bar pop-down interface to configure the GNOME Shell Screencast Recording feature."
arch=('any')
@@ -16,22 +16,22 @@ source=("${pkgname}::git+https://github.com/iacopodeenosee/EasyScreenCast.git")
sha512sums=('SKIP')
_branch=master
+prepare() {
+ cd "${pkgname}"
+ git checkout ${_branch}
+ git pull
+}
+
pkgver() {
- cd "${srcdir}/${pkgname}"
- git checkout ${_branch} --quiet
+ cd "${pkgname}"
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
-prepare() {
- cd "${srcdir}/${pkgname}"
- git checkout ${_branch}
-}
-
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}"
# Locate the extension.
_extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
_destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"