summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex S2017-11-20 21:14:40 +0100
committerAlex S2017-11-20 21:14:40 +0100
commit44358728b4140e75cd84318b87ea7f1f99cb6357 (patch)
tree43014b9c13da8285cb326383d3901667c88991b9
downloadaur-44358728b4140e75cd84318b87ea7f1f99cb6357.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--gnome-shell-extension-easyscreencast.install7
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b124bd7465f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-shell-extension-easyscreencast-origin-git
+ pkgdesc = This extension simplifies the use of the video recording function integrated in gnome shell, allows quickly to change the various settings of the desktop recording.
+ pkgver = 0.10.r67.g9322adf
+ pkgrel = 0
+ url = https://github.com/EasyScreenCast/EasyScreenCast
+ install = gnome-shell-extension-easyscreencast.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-easyscreencast
+ conflicts = gnome-shell-extension-easyscreencast
+ conflicts = gnome-shell-extension-easyscreencast-git
+ source = git://github.com/EasyScreenCast/EasyScreenCast.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-easyscreencast-origin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cc37ec857f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alex S. shantanna_at_hotmail_dot_com>
+
+pkgname=gnome-shell-extension-easyscreencast-origin-git
+_gitname=easyscreencast
+pkgver=0.10.r67.g9322adf
+pkgrel=0
+pkgdesc="This extension simplifies the use of the video recording function integrated in gnome shell, allows quickly to change the various settings of the desktop recording."
+arch=('any')
+url="https://github.com/EasyScreenCast/EasyScreenCast"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+provides=("${pkgname%-*-*}")
+conflicts=("${provides}" "${provides}-git")
+install=${provides}.install
+source=('git://github.com/EasyScreenCast/EasyScreenCast.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ _extid="EasyScreenCast@iacopodeenosee.gmail.com"
+ cd "${srcdir}/${_gitname}"
+ make _build
+ mv _build ${_extid}
+
+ install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${provides}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -af "${_extid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+}
diff --git a/gnome-shell-extension-easyscreencast.install b/gnome-shell-extension-easyscreencast.install
new file mode 100644
index 000000000000..3bde516d209a
--- /dev/null
+++ b/gnome-shell-extension-easyscreencast.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo ''
+ echo '==> To enable EasyScreenCast:'
+ echo '==> Reload Gnome Shell with Alt-F2 r'
+ echo '==> Enable it with gnome-tweak-tool or "gnome-shell-extension-tool -e EasyScreenCast@iacopodeenosee.gmail.com"'
+ echo ''
+}