summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-11-06 19:31:43 +0300
committerIgor Dyatlov2022-11-06 19:31:43 +0300
commitd680a8096996e6799d1854831ee2716e03fd382c (patch)
treeb80340f3557f6ce9639e012ec96e6531221ec698
downloadaur-d680a8096996e6799d1854831ee2716e03fd382c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f04b2acf3d32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-fly-pie-git
+ pkgdesc = Fly-Pie is an innovative marking menu written as a GNOME Shell extension
+ pkgver = 17.r6.gdafe2af
+ pkgrel = 1
+ url = https://github.com/Schneegans/Fly-Pie
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = zip
+ depends = gnome-shell
+ provides = gnome-shell-extension-fly-pie
+ conflicts = gnome-shell-extension-fly-pie
+ source = gnome-shell-extension-fly-pie::git+https://github.com/Schneegans/Fly-Pie.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-fly-pie-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04c7f959fde3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=gnome-shell-extension-fly-pie-git
+pkgver=17.r6.gdafe2af
+pkgrel=1
+pkgdesc="Fly-Pie is an innovative marking menu written as a GNOME Shell extension"
+arch=('any')
+url="https://github.com/Schneegans/Fly-Pie"
+license=('MIT')
+depends=('gnome-shell')
+makedepends=('git' 'zip')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(${pkgname%-git}::git+$url.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+
+ make zip
+}
+
+package() {
+ cd "${pkgname%-git}"
+ _uuid='flypie@schneegans.github.com'
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ bsdtar -xvf $_uuid.zip -C "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+}