summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2018-08-10 16:15:40 -0700
committerLlewelyn Trahaearn2018-08-10 16:15:40 -0700
commit7dbadf9c1036ad45ecc65788f5c84ca6c0fef949 (patch)
tree51e0f1e13151dad0ce0abf192d06ecd6a6ccca16
parent2d21d5ff15b12735948b3da3ad44128d04b9145e (diff)
downloadaur-7dbadf9c1036ad45ecc65788f5c84ca6c0fef949.tar.gz
Fix localization.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d22f501d38d5..b513fbe1cbbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = gnome-shell-extension-freon-git
pkgdesc = Displays: CPU temperature, HDD/SSD temperature, video card temperature (nVidia/Catalyst), voltage and fan RPM in a GNOME Shell top bar pop-down.
- pkgver = 34.r0.g2d8e169
+ pkgver = 34.r2.gc8b27ac
pkgrel = 1
url = https://github.com/UshakovVasilii/gnome-shell-extension-freon
install = gschemas.install
arch = any
license = GPL
makedepends = git
- makedepends = gnome-common
- makedepends = intltool
depends = dconf
depends = gnome-shell
depends = lm_sensors
diff --git a/PKGBUILD b/PKGBUILD
index 84d9ed518d29..734717fdd7d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
pkgname=gnome-shell-extension-freon-git
-pkgver=34.r0.g2d8e169
+pkgver=34.r2.gc8b27ac
pkgrel=1
pkgdesc="Displays: CPU temperature, HDD/SSD temperature, video card temperature (nVidia/Catalyst), voltage and fan RPM in a GNOME Shell top bar pop-down."
arch=('any')
url="https://github.com/UshakovVasilii/gnome-shell-extension-freon"
license=('GPL')
depends=('dconf' 'gnome-shell' 'lm_sensors')
-makedepends=('git' 'gnome-common' 'intltool')
+makedepends=('git')
optdepends=(
'udisks2: optional backend for storage temperature sensors.'
'hddtemp: optional backend for S.M.A.R.T. temperature sensors.'
@@ -43,4 +43,9 @@ package() {
find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "${_destdir}" '{}' +
find -maxdepth 2 \( -iname '*.svg*' \) -exec install -Dm644 -t "${_destdir}/icons" '{}' +
find -name '*.xml' -exec install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" '{}' +
+ cd locale
+ for locale in */
+ do
+ install -Dm644 -t "${pkgdir}/usr/share/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
+ done
}