summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrewmate2021-04-30 21:48:59 -0700
committerCrewmate2021-04-30 21:48:59 -0700
commitc463d526c9a27acfae72b984de9a4511e9513166 (patch)
treeba88224724ce8a5c06b5961425469f38414b20f2
downloadaur-gnome-shell-extension-fullscreen-notifications-git.tar.gz
the first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05270e7f83a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-fullscreen-notifications-git
+ pkgdesc = Extension that enables all notifications in fullscreen mode
+ pkgver = 4
+ pkgrel = 1
+ url = https://github.com/soal/gnome-shell-extension-fullscreen-notifications
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell
+ source = git+https://github.com/soal/gnome-shell-extension-fullscreen-notifications
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-fullscreen-notifications-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed2abc4b13be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer Crewmate <sus@morshu.xyz>
+pkgname=gnome-shell-extension-fullscreen-notifications-git
+_pkgname=gnome-shell-extension-fullscreen-notifications
+pkgver=4
+pkgrel=1
+pkgdesc="Extension that enables all notifications in fullscreen mode"
+arch=('any')
+url="https://github.com/soal/gnome-shell-extension-fullscreen-notifications"
+license=(GPL2)
+depends=('gnome-shell')
+makedepends=('git')
+source=("git+https://github.com/soal/gnome-shell-extension-fullscreen-notifications")
+md5sums=('SKIP')
+
+build() {
+ return 0
+}
+
+package() {
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -r $srcdir/$_pkgname/fullscreen-notifications@sorrow.about.alice.pm.me $pkgdir/usr/share/gnome-shell/extensions/
+ install -Dm644 $srcdir/$_pkgname/LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+}