summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-10 09:06:07 -0600
committerMark Wagie2021-06-10 09:06:07 -0600
commita571a90877359934bb638399bd822971cca836e1 (patch)
tree8f1b012ab895328fc785c7bc96e7b066cc59cb80
parentb82df79eb54f7a880f4c850fba8825bf62ee2ac5 (diff)
downloadaur-a571a90877359934bb638399bd822971cca836e1.tar.gz
remove patch
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 6 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bce32871b7bb..de22e723867e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-gamemode-git
pkgdesc = GNOME Shell extension for Feral Interactive's GameMode
- pkgver = 4.r7.gac23266
- pkgrel = 2
+ pkgver = 5.r1.ga3c13ae
+ pkgrel = 1
url = https://github.com/gicmo/gamemode-extension
arch = any
license = GPL2
@@ -12,9 +12,6 @@ pkgbase = gnome-shell-extension-gamemode-git
provides = gnome-shell-extension-gamemode
conflicts = gnome-shell-extension-gamemode
source = git+https://github.com/gicmo/gamemode-extension.git
- source = https://github.com/gicmo/gamemode-extension/pull/38.patch
sha256sums = SKIP
- sha256sums = c49558889af2f2f991abe9c7c8d48783f7a719a26e1e72c4751dcbe787794f86
pkgname = gnome-shell-extension-gamemode-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3e18e5663f7a..031ab54ff77b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota.com>
# Contributor: Luke Street <luke.street@encounterpc.com>
pkgname=gnome-shell-extension-gamemode-git
-pkgver=4.r7.gac23266
-pkgrel=2
+pkgver=5.r1.ga3c13ae
+pkgrel=1
pkgdesc="GNOME Shell extension for Feral Interactive's GameMode"
arch=('any')
url="https://github.com/gicmo/gamemode-extension"
@@ -11,23 +11,14 @@ depends=('gamemode' 'gnome-shell')
makedepends=('meson' 'git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/gicmo/gamemode-extension.git'
- 'https://github.com/gicmo/gamemode-extension/pull/38.patch')
-sha256sums=('SKIP'
- 'c49558889af2f2f991abe9c7c8d48783f7a719a26e1e72c4751dcbe787794f86')
+source=('git+https://github.com/gicmo/gamemode-extension.git')
+sha256sums=('SKIP')
pkgver() {
cd $srcdir/gamemode-extension
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd $srcdir/gamemode-extension
-
- # support for gnome-shell40/gtk4
- patch -Np1 -i $srcdir/38.patch
-}
-
build() {
arch-meson gamemode-extension build
meson compile -C build