summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Dickson2017-11-26 11:32:38 -0800
committerScott Dickson2017-11-26 11:32:38 -0800
commit4bc701e8b8eec45ccfd2be4f9a4b5f0a71ee7b1e (patch)
tree4614f6087fb54ce81db6e7d73992085c45b407e4
downloadaur-4bc701e8b8eec45ccfd2be4f9a4b5f0a71ee7b1e.tar.gz
First commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b670ddb26a32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-gnomenu
+ pkgdesc = GnoMenu - is a traditional styled full featured Gnome-Shell apps-menu, that aims to offer all the essentials in a simple uncluttered intuitive interface.
+ pkgver = 23
+ pkgrel = 1
+ url = https://github.com/The-Panacea-Projects/Gnomenu
+ arch = any
+ license = GPL3
+ depends = gnome-shell
+ source = https://github.com/The-Panacea-Projects/Gnomenu/archive/gno-menu.v23.tar.gz
+ sha256sums = 3255ee9a9f54a395b1288cdd81fedbcaacfb6a389dcc74181cd57e9b82ab4fc6
+
+pkgname = gnome-shell-extension-gnomenu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6a2a1227de9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Scott Dickson <scottfoesho@gmail.com>
+
+pkgname=gnome-shell-extension-gnomenu
+pkgver=23
+pkgrel=1
+pkgdesc="GnoMenu - is a traditional styled full featured Gnome-Shell apps-menu, that aims to offer all the essentials in a simple uncluttered intuitive interface."
+arch=('any')
+url="https://github.com/The-Panacea-Projects/Gnomenu"
+license=('GPL3')
+depends=('gnome-shell')
+source=("https://github.com/The-Panacea-Projects/Gnomenu/archive/gno-menu.v${pkgver}.tar.gz")
+sha256sums=('3255ee9a9f54a395b1288cdd81fedbcaacfb6a389dcc74181cd57e9b82ab4fc6')
+
+package() {
+ _extname='gnomenu@panacier.gmail.com'
+
+ cd "${srcdir}/Gnomenu-gno-menu.v${pkgver}"
+ rm README.md Screenshot.png
+
+ install -Dm644 extension.js -t "${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+ install -Dm644 metadata.json -t "${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+}