summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK5HV2018-05-24 16:33:21 +0200
committerK5HV2018-05-24 16:33:21 +0200
commit388d3015179e472d5aad38964d3272a1d14ec515 (patch)
tree2dc7b62aff5265a79c0ec9bd50e1733c940a4c05
downloadaur-388d3015179e472d5aad38964d3272a1d14ec515.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d916f43b67e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-gnomenu-git
+ pkgdesc = GnoMenu - is a traditional styled full featured Gnome-Shell apps-menu, that aims to offer all the essentials in a simple uncluttered intuitive interface.
+ pkgver = v25.g21c5623
+ pkgrel = 1
+ url = https://github.com/The-Panacea-Projects/Gnomenu
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ conflicts = gnome-shell-extension-gnomenu
+ source = git+https://github.com/The-Panacea-Projects/Gnomenu
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-gnomenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dc36dbd55bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Rafal Malachowicz <k5hv@linux.pl>
+# Based on gnome-shell-extension-gnomenu PKGBUILD maintained by: Scott Dickson <scottfoesho@gmail.com>
+
+_pkgname=gnome-shell-extension-gnomenu
+pkgname=$_pkgname-git
+pkgver=v25.g21c5623
+pkgrel=1
+pkgdesc="GnoMenu - is a traditional styled full featured Gnome-Shell apps-menu, that aims to offer all the essentials in a simple uncluttered intuitive interface."
+arch=('any')
+url="https://github.com/The-Panacea-Projects/Gnomenu"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+conflicts=($_pkgname)
+source=('git+https://github.com/The-Panacea-Projects/Gnomenu')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/Gnomenu"
+ git describe --long --tags | cut -d '.' -f 2 | awk -F '-' '{print $1"."$3}'
+}
+
+package() {
+ _extname='gnomenu@panacier.gmail.com'
+
+ cd "$srcdir/Gnomenu"
+ rm README.md Screenshot.png
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${_extname}"
+ cp -r . "$pkgdir/usr/share/gnome-shell/extensions/${_extname}/"
+}