summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMárk Sági-Kazár2016-01-06 00:08:33 +0100
committerMárk Sági-Kazár2016-01-06 00:08:33 +0100
commite861869b3467d4ef17beacaa3e40ad69dc5fc0d3 (patch)
tree60de7f4d2a30464ea54f956c61556ad1f555bf96
downloadaur-e861869b3467d4ef17beacaa3e40ad69dc5fc0d3.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--gschemas.install21
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e5f407bd352
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Jan 5 22:58:20 UTC 2016
+pkgbase = gnome-shell-extension-gravatar
+ pkgdesc = A GNOME Shell extension to synchronize your user icon with Gravatar.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/jrouleau/gnome-shell-extension-gravatar
+ install = gschemas.install
+ arch = any
+ license = MIT
+ depends = gnome-shell
+ optdepends = dconf
+ optdepends = gnome-tweak-tool
+ optdepends = gnome-shell-extension-prefs
+ conflicts = gnome-shell-extension-gravatar-git
+ source = https://github.com/jrouleau/gnome-shell-extension-gravatar/archive/v1.tar.gz
+ md5sums = 289cdbaf6cc842eb6473607665c89aaa
+
+pkgname = gnome-shell-extension-gravatar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a17221fb83d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Márk Sági-Kazár <mark.sagi-kazar@gmail.com>
+
+pkgname=gnome-shell-extension-gravatar
+pkgver=1
+pkgrel=1
+pkgdesc="A GNOME Shell extension to synchronize your user icon with Gravatar."
+arch=('any')
+url="https://github.com/jrouleau/gnome-shell-extension-gravatar"
+license=('MIT')
+depends=('gnome-shell')
+optdepends=('dconf' 'gnome-tweak-tool' 'gnome-shell-extension-prefs')
+conflicts=("${pkgname}-git")
+install=gschemas.install
+source=("https://github.com/jrouleau/gnome-shell-extension-gravatar/archive/v${pkgver}.tar.gz")
+noextract=()
+md5sums=('289cdbaf6cc842eb6473607665c89aaa')
+
+_uuid='gravatar@jr.rlabs.io'
+
+package() {
+ cd "${srcdir}/gnome-shell-extension-gravatar-${pkgver}"
+
+ _extension_path="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ _schema_path="${pkgdir}/usr/share/glib-2.0/schemas"
+
+ install -d $_extension_path
+ install -d $_schema_path
+
+ install -Dm644 src/schemas/org.gnome.shell.extensions.gravatar.gschema.xml $_schema_path
+ rm -rf src/schemas
+
+ cp -r src/* $_extension_path
+ cp -r lib/ $_extension_path
+ cp LICENSE $_extension_path
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..48d0b724fb6c
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,21 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_install
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions() {
+ echo "Restart GNOME Shell ([Alt]+[F2], r)."
+}
+
+instructions_install() {
+ echo "Dconf blablabla"
+}