summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-04-12 10:55:20 +0200
committerTérence Clastres2019-04-12 10:55:20 +0200
commitd5da2c76ccf1d97f0b5487bcfac2ab0a17a4fd53 (patch)
tree55d72f85909dd00f8636a9e2e121d63200ef101e
downloadaur-d5da2c76ccf1d97f0b5487bcfac2ab0a17a4fd53.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31b4f57a0b8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-gtktitlebar-git
+ pkgdesc = A GNOME Shell extension that GTK Title Bar - Remove Title Bar for non-GTK Software
+ pkgver = r3.dce6fe6
+ pkgrel = 1
+ url = https://github.com/velitasali/GTKTitleBar
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell>=3.28
+ provides = gnome-shell-extension-gtktitlebar
+ source = gnome-shell-extension-gtktitlebar-git::git+https://github.com/velitasali/GTKTitleBar
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-gtktitlebar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81f8987c0ae2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Térence Clastres <t.clastres@gmail.com>
+
+pkgname=gnome-shell-extension-gtktitlebar-git
+pkgver=r3.dce6fe6
+pkgrel=1
+pkgdesc="A GNOME Shell extension that GTK Title Bar - Remove Title Bar for non-GTK Software"
+arch=('any')
+url="https://github.com/velitasali/GTKTitleBar"
+license=('GPL2')
+depends=('gnome-shell>=3.28')
+makedepends=('git')
+provides=("${pkgname/-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
+ cp -R "gtktitlebar@velitasali.github.io" "$pkgdir/usr/share/gnome-shell/extensions"
+}