summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-01-16 19:31:10 +0300
committerIgor Dyatlov2022-01-16 19:31:10 +0300
commitb8e4d18437ca5a59ef7fb6d2776ad60de93f3492 (patch)
tree56049149fdde8b15f47a0bd5a5840f6e5bd91ff8
parentc2ac37f896e1c0ac899402cc6a70cae2e1e2aa7f (diff)
downloadaur-b8e4d18437ca5a59ef7fb6d2776ad60de93f3492.tar.gz
Updates
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6c90d756431..623699191f8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-hibernate
pkgdesc = A GNOME extension that adds the option to hibernate amongst other system actions
- pkgver = 7
+ pkgver = 8
pkgrel = 1
url = https://codeberg.org/kiyui/gnome-shell-hibernate-extension
arch = any
@@ -8,7 +8,7 @@ pkgbase = gnome-shell-extension-hibernate
makedepends = meson
depends = gnome-shell
depends = gnome-shell-extensions
- source = https://codeberg.org/kiyui/gnome-shell-hibernate-extension/archive/7.tar.gz
- sha256sums = 4232980e25cf156c4425c48f696dbaae6f6998a2877a9c6bbf6215ad4db58c66
+ source = https://codeberg.org/kiyui/gnome-shell-hibernate-extension/archive/8.tar.gz
+ b2sums = c03d77c07ae1e8a85c6f89ef6c5b8a96a59e93cf6db567bab4a7b3c689335b9f01344571650aba81d645db6b8175341fb7249564b0222414be403aa27838ead0
pkgname = gnome-shell-extension-hibernate
diff --git a/PKGBUILD b/PKGBUILD
index 02c011eba00d..f7108329ba0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gnome-shell-extension-hibernate
_pkgname=gnome-shell-hibernate-extension
-pkgver=7
+pkgver=8
pkgrel=1
pkgdesc="A GNOME extension that adds the option to hibernate amongst other system actions"
arch=('any')
@@ -11,13 +11,18 @@ license=('GPL2')
depends=('gnome-shell' 'gnome-shell-extensions')
makedepends=('meson')
source=($url/archive/$pkgver.tar.gz)
-sha256sums=('4232980e25cf156c4425c48f696dbaae6f6998a2877a9c6bbf6215ad4db58c66')
+b2sums=('c03d77c07ae1e8a85c6f89ef6c5b8a96a59e93cf6db567bab4a7b3c689335b9f01344571650aba81d645db6b8175341fb7249564b0222414be403aa27838ead0')
build() {
arch-meson $_pkgname build
meson compile -C build
}
+check() {
+ meson test -C build
+}
+
+
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}