diff options
author | XZS | 2015-08-06 14:44:02 +0200 |
---|---|---|
committer | XZS | 2015-08-06 14:44:02 +0200 |
commit | 7093453905adfba2e469fe0fa73270ffe046faed (patch) | |
tree | 727642349a038d99d79cde52164c508757dce646 | |
parent | 78bfe2479bd79644361620333735e54e82b29428 (diff) | |
download | aur-7093453905adfba2e469fe0fa73270ffe046faed.tar.gz |
sort package functions
-rw-r--r-- | PKGBUILD | 50 |
1 files changed, 25 insertions, 25 deletions
@@ -21,22 +21,6 @@ pkgver() { [ ${PIPESTATUS[0]} -ne 0 ] && \ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" } -depends[gnomeshell]=gnome-shell - -package_20_version() { - local compatibles=($(\ - find -path ./pkg -type d -prune -o \ - -name metadata.json -exec grep -Pzo '(?s)(?<="shell-version": \[)[^\[\]]*(?=\])' '{}' \; | \ - tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1)) - depends+=("gnome-shell>=3.${compatibles[0]}") - local max="${compatibles[-1]}" - if [ "3.$max" != $( - gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+' - ) ]; then - depends+=("gnome-shell<3.$((${max%%.*} + 1))") - fi - unset depends[gnomeshell] -} package() { for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$') do @@ -54,15 +38,6 @@ package_02_install() { msg2 'Installing extension code...' find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "$destdir" '{}' + } -if [ -z "$install" ] -then - install=gschemas.install -fi - -package_10_schemas() { - msg2 'Installing schemas...' - find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' + -} package_10_locale() { msg2 'Installing translations...' ( @@ -73,3 +48,28 @@ package_10_locale() { done ) } +if [ -z "$install" ] +then + install=gschemas.install +fi + +package_10_schemas() { + msg2 'Installing schemas...' + find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' + +} +depends[125]=gnome-shell + +package_20_version() { + local compatibles=($(\ + find -path ./pkg -type d -prune -o \ + -name metadata.json -exec grep -Pzo '(?s)(?<="shell-version": \[)[^\[\]]*(?=\])' '{}' \; | \ + tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1)) + depends+=("gnome-shell>=3.${compatibles[0]}") + local max="${compatibles[-1]}" + if [ "3.$max" != $( + gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+' + ) ]; then + depends+=("gnome-shell<3.$((${max%%.*} + 1))") + fi + unset depends[125] +} |