summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-11-08 20:11:49 +0300
committerIgor Dyatlov2022-11-08 20:11:49 +0300
commit00ed2cbb6c92428bbedd4800c77a1456416f341e (patch)
tree0349396b47d0c96492f5468092b6bdf6e734cc32
downloadaur-00ed2cbb6c92428bbedd4800c77a1456416f341e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf2369b609f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-hotkeys-popup-git
+ pkgdesc = GNOME Shell Extension that displays currently configured Gnome hotkeys in a popup.
+ pkgver = 4.r10.g0b11b5e
+ pkgrel = 1
+ url = https://github.com/mipmip/gnome-shell-extensions-hotkeys-popup
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = zip
+ depends = gnome-shell
+ provides = gnome-shell-extension-hotkeys-popup
+ conflicts = gnome-shell-extension-hotkeys-popup
+ source = gnome-shell-extension-hotkeys-popup::git+https://github.com/mipmip/gnome-shell-extensions-hotkeys-popup.git
+ b2sums = SKIP
+
+pkgname = gnome-shell-extension-hotkeys-popup-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d54becedfd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=gnome-shell-extension-hotkeys-popup-git
+pkgver=4.r10.g0b11b5e
+pkgrel=1
+pkgdesc="GNOME Shell Extension that displays currently configured Gnome hotkeys in a popup."
+arch=('any')
+url="https://github.com/mipmip/gnome-shell-extensions-hotkeys-popup"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git' 'zip')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(${pkgname%-git}::git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+
+ ./install.sh zip
+}
+
+package() {
+ _uuid='hotkeys-popup@pimsnel.com'
+ cd "${pkgname%-git}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ bsdtar -xvf $_uuid.zip -C "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+}