summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwout van Mansom2022-11-30 19:32:11 +0100
committerEwout van Mansom2022-11-30 19:32:11 +0100
commit161b216f79550b56681c9908c83c45a102126404 (patch)
treea8fc5de6e4be53616f353659493857520d676437
downloadaur-161b216f79550b56681c9908c83c45a102126404.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f20177d70b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-jiggle
+ pkgdesc = Gnome extension that highlights the cursor position when the mouse is moved rapidly.
+ pkgver = 8+r38+g436d1cf
+ pkgrel = 1
+ url = https://github.com/jeffchannell/jiggle
+ arch = any
+ groups = gnome-shell-extensions
+ license = GPL3
+ makedepends = git
+ makedepends = glib2
+ makedepends = unzip
+ depends = gnome-shell>=1:43
+ source = git+https://github.com/jeffchannell/jiggle.git#commit=436d1cf6f10e76ff27ce4775e8ebe666dc9d60c3
+ b2sums = SKIP
+
+pkgname = gnome-shell-extension-jiggle
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2f8e3970af7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ewout van Mansom <ewout@vanmansom.name>
+_extname=jiggle
+_uuid=jiggle-dev@jeffchannell.com
+pkgname=gnome-shell-extension-jiggle
+pkgver=8+r38+g436d1cf
+pkgrel=1
+pkgdesc='Gnome extension that highlights the cursor position when the mouse is moved rapidly.'
+arch=('any')
+url='https://github.com/jeffchannell/jiggle'
+license=('GPL3')
+groups=('gnome-shell-extensions')
+depends=('gnome-shell>=1:43')
+makedepends=('git' 'glib2' 'unzip')
+_commit=436d1cf6f10e76ff27ce4775e8ebe666dc9d60c3 # master^0
+source=("git+${url}.git#commit=${_commit}")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ glib-compile-schemas schemas/
+ make build
+}
+
+check() {
+ cd "${srcdir}/${_extname}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${_extname}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ unzip jiggle_latest.zip -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ chown root:root -R "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+}