summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwout van Mansom2022-11-30 19:53:44 +0100
committerEwout van Mansom2022-11-30 19:53:44 +0100
commit2784e596bfeb972e6cbbaaaca10c99177a1af5b5 (patch)
treef5df4d428af40801cca7cc0d85428b2653501fe3
parent9ef6a803544ddef9f70d0fe91e721558d32931a3 (diff)
downloadaur-2784e596bfeb972e6cbbaaaca10c99177a1af5b5.tar.gz
add patch for GNOME 43 compatibility
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--gnome43-comp.patch21
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60be16632c67..c7fc2e3bb434 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-jiggle
pkgdesc = Gnome extension that highlights the cursor position when the mouse is moved rapidly.
pkgver = 8+r38+g436d1cf
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jeffchannell/jiggle
arch = any
groups = gnome-shell-extensions
@@ -11,6 +11,8 @@ pkgbase = gnome-shell-extension-jiggle
makedepends = unzip
depends = gnome-shell>=1:43
source = git+https://github.com/jeffchannell/jiggle.git#commit=436d1cf6f10e76ff27ce4775e8ebe666dc9d60c3
+ source = gnome43-comp.patch::https://patch-diff.githubusercontent.com/raw/jeffchannell/jiggle/pull/68.patch
b2sums = SKIP
+ b2sums = 3c020ba17d9ed52c627c41779dac81cf53c059e632b7bc677168f9819c9d79453178b0ff132b45d259340006021f2b5592612b4f69b6ef4d514701ef66fefe8e
pkgname = gnome-shell-extension-jiggle
diff --git a/PKGBUILD b/PKGBUILD
index a1ca86d303ee..0e4261b78380 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _extname=jiggle
_uuid=jiggle-dev@jeffchannell.com
pkgname=gnome-shell-extension-jiggle
pkgver=8+r38+g436d1cf
-pkgrel=2
+pkgrel=3
pkgdesc='Gnome extension that highlights the cursor position when the mouse is moved rapidly.'
arch=('any')
url='https://github.com/jeffchannell/jiggle'
@@ -12,8 +12,17 @@ groups=('gnome-shell-extensions')
depends=('gnome-shell>=1:43')
makedepends=('git' 'glib2' 'unzip')
_commit=436d1cf6f10e76ff27ce4775e8ebe666dc9d60c3 # master^0
-source=("git+${url}.git#commit=${_commit}")
-b2sums=('SKIP')
+source=(
+ "git+${url}.git#commit=${_commit}"
+ "gnome43-comp.patch::https://patch-diff.githubusercontent.com/raw/jeffchannell/jiggle/pull/68.patch"
+)
+b2sums=('SKIP'
+ '3c020ba17d9ed52c627c41779dac81cf53c059e632b7bc677168f9819c9d79453178b0ff132b45d259340006021f2b5592612b4f69b6ef4d514701ef66fefe8e')
+
+prepare() {
+ cd "${srcdir}/${_extname}"
+ patch --forward --strip=1 --input="${srcdir}/gnome43-comp.patch"
+}
pkgver() {
cd "${srcdir}/${_extname}"
diff --git a/gnome43-comp.patch b/gnome43-comp.patch
new file mode 100644
index 000000000000..2b78171ab782
--- /dev/null
+++ b/gnome43-comp.patch
@@ -0,0 +1,21 @@
+From 21881bc7a7a669029fc1e4ea2353cc19d6ad0503 Mon Sep 17 00:00:00 2001
+From: Ewout van Mansom <ewout@vanmansom.name>
+Date: Wed, 30 Nov 2022 19:02:49 +0100
+Subject: [PATCH] update metadata.json: GNOME 43 support
+
+---
+ metadata.json | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/metadata.json b/metadata.json
+index b39657a..ad4f2be 100644
+--- a/metadata.json
++++ b/metadata.json
+@@ -3,6 +3,6 @@
+ "name": "Jiggle",
+ "description": "Jiggle is a Gnome Shell extension that highlights the cursor position when the mouse is moved rapidly.",
+ "url": "https://github.com/jeffchannell/jiggle",
+- "shell-version": [ "40", "41", "42" ],
++ "shell-version": [ "40", "41", "42", "43" ],
+ "version": "9"
+ }