summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwout van Mansom2022-12-02 22:36:40 +0100
committerEwout van Mansom2022-12-02 22:36:40 +0100
commit94f6e7129b07a0b575bdfd42d1bd2ae7bf1897e1 (patch)
treeec841b943fd91c46a6c0cffead4c4e52f62e5787
parent994fb3727e94f572ff447c0b62ab6365fc191a5a (diff)
downloadaur-94f6e7129b07a0b575bdfd42d1bd2ae7bf1897e1.tar.gz
add patch for loading system-wide gschema
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5499421616e4..0cc63c742bef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-jiggle
pkgdesc = Gnome extension that highlights the cursor position when the mouse is moved rapidly.
pkgver = 8+r38+g436d1cf
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/jeffchannell/jiggle
arch = any
groups = gnome-shell-extensions
@@ -12,7 +12,9 @@ pkgbase = gnome-shell-extension-jiggle
depends = gnome-shell>=1:43
source = git+https://github.com/jeffchannell/jiggle.git#commit=436d1cf6f10e76ff27ce4775e8ebe666dc9d60c3
source = gnome43-comp.patch::https://patch-diff.githubusercontent.com/raw/jeffchannell/jiggle/pull/68.patch
+ source = system-wide-gschema-fix.patch::https://patch-diff.githubusercontent.com/raw/jeffchannell/jiggle/pull/70.patch
b2sums = SKIP
b2sums = 3c020ba17d9ed52c627c41779dac81cf53c059e632b7bc677168f9819c9d79453178b0ff132b45d259340006021f2b5592612b4f69b6ef4d514701ef66fefe8e
+ b2sums = 3f1775ce78220acd591b46f0822a5d1a3efa827edc2c8bafd6fdd625969aa94483022e19475afee840259b085c1a4697852b8b230b80e9a2441d741153c260e3
pkgname = gnome-shell-extension-jiggle
diff --git a/PKGBUILD b/PKGBUILD
index 491eef6cc7a3..d03724ddd418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _extname=jiggle
_uuid=jiggle@jeffchannell.com
pkgname=gnome-shell-extension-jiggle
pkgver=8+r38+g436d1cf
-pkgrel=8
+pkgrel=9
pkgdesc='Gnome extension that highlights the cursor position when the mouse is moved rapidly.'
arch=('any')
url='https://github.com/jeffchannell/jiggle'
@@ -15,13 +15,16 @@ _commit=436d1cf6f10e76ff27ce4775e8ebe666dc9d60c3 # master^0
source=(
"git+${url}.git#commit=${_commit}"
"gnome43-comp.patch::https://patch-diff.githubusercontent.com/raw/jeffchannell/jiggle/pull/68.patch"
+ "system-wide-gschema-fix.patch::https://patch-diff.githubusercontent.com/raw/jeffchannell/jiggle/pull/70.patch"
)
b2sums=('SKIP'
- '3c020ba17d9ed52c627c41779dac81cf53c059e632b7bc677168f9819c9d79453178b0ff132b45d259340006021f2b5592612b4f69b6ef4d514701ef66fefe8e')
+ '3c020ba17d9ed52c627c41779dac81cf53c059e632b7bc677168f9819c9d79453178b0ff132b45d259340006021f2b5592612b4f69b6ef4d514701ef66fefe8e'
+ '3f1775ce78220acd591b46f0822a5d1a3efa827edc2c8bafd6fdd625969aa94483022e19475afee840259b085c1a4697852b8b230b80e9a2441d741153c260e3')
prepare() {
cd "${srcdir}/${_extname}"
patch --forward --strip=1 --input="${srcdir}/gnome43-comp.patch"
+ patch --forward --strip=1 --input="${srcdir}/system-wide-gschema-fix.patch"
}
pkgver() {