aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaúl Romero García2015-10-10 16:28:40 +0200
committerRaúl Romero García2015-10-10 16:28:40 +0200
commit23cbaf118c3e521ec1dfab3ef6ce68e3c026858b (patch)
treeee63a83da2673dc0ff4564fe016869e4061a2261
downloadaur-23cbaf118c3e521ec1dfab3ef6ce68e3c026858b.tar.gz
r109
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD49
-rwxr-xr-xgschemas.install13
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6632ce405bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-laine-git
+ pkgdesc = Gnome extension which allows the control of the volume of individual applications as well as a more in depth control of mpris aware applications from a single applet
+ pkgver = r109.5ba80c0
+ pkgrel = 1
+ url = https://github.com/johnhoran/Laine
+ install = gschemas.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = dconf
+ provides = gnome-shell-extension-laine
+ conflicts = gnome-shell-extension-laine
+ source = gnome-shell-extension-laine::git+https://github.com/johnhoran/Laine
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-laine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8f81c9ab5cbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+pkgname="gnome-shell-extension-laine-git"
+pkgdesc="Gnome extension which allows the control of the volume of individual applications as well as a more in depth control of mpris aware applications from a single applet"
+pkgver=r109.5ba80c0
+pkgrel=1
+arch=(any)
+url="https://github.com/johnhoran/Laine"
+license=('GPL2')
+
+makedepends+=('git')
+source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
+md5sums+=('SKIP')
+provides+=($_gitname)
+conflicts+=($_gitname)
+depends[dconf]=dconf
+pkgver() {
+ cd ${_gitname:-$pkgname}
+ git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
+ [ ${PIPESTATUS[0]} -ne 0 ] && \
+printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
+ do
+ $function
+ done
+}
+
+package_01_locate() {
+ msg2 'Locating extension...'
+ cd "$(dirname $(find -name 'metadata.json'))"
+ extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
+}
+
+package_02_install() {
+ msg2 'Installing extension code...'
+ find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "$destdir" '{}' +
+}
+
+if [ -z "$install" ]
+then
+ install=gschemas.install
+fi
+
+package_10_schemas() {
+ msg2 'Installing schemas...'
+ find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' +
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100755
index 000000000000..29753c3fa523
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: