aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaúl Romero García2018-03-01 06:34:44 +0100
committerRaúl Romero García2018-03-01 06:57:35 +0100
commitc680de548bef37aa131da220cd6a38dee6007a2c (patch)
tree510eeba65b0d1eca5b540427326a774f7ecf17c2
parentc9aa5827305cd2b906cd3be9096bfa33b4e9c470 (diff)
downloadaur-c680de548bef37aa131da220cd6a38dee6007a2c.tar.gz
Updated pkgver generation
getzze says: The last tag contains a hyphen so pkgver generates an incorrect version number. Modify the sed line with what is advised in the wiki (https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function) makes it work.
-rwxr-xr-xPKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21b9ff7e4a18..07f9386d75bc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname="gnome-shell-extension-laine-git"
pkgdesc="Gnome extension which allows the control of the volume of individual applications as well as a more in depth control of mpris aware applications from a single applet"
-pkgver=3.24.r2.g838d89e
+pkgver=v3.26.10.r0.gd0c9774
pkgrel=1
arch=(any)
url="https://github.com/johnhoran/Laine"
@@ -14,7 +14,7 @@ conflicts+=($_gitname)
pkgver() {
cd ${_gitname:-$pkgname}
- git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
[ ${PIPESTATUS[0]} -ne 0 ] && \
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}