aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaúl Romero García2021-09-24 12:04:52 +0200
committerRaúl Romero García2021-09-24 12:04:52 +0200
commitf959453e0d9fa9f625c46e8d5665636f338be520 (patch)
tree0d7c402a1c5c67b96c559b4cd2b418f61f014a72
parenta0a2b2994da0a865ccf15d6d5d2c1e52482d1c5e (diff)
downloadaur-f959453e0d9fa9f625c46e8d5665636f338be520.tar.gz
Fixed pkver error reported by @HMlendea
-rwxr-xr-xPKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae1e955cdabd..035bdc62cf5c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname="gnome-shell-extension-laine-git"
pkgdesc="Gnome extension which allows the control of the volume of individual applications as well as a more in depth control of mpris aware applications from a single applet"
-pkgver=3.32.r3.g511e819
+pkgver=3.32.r43.gc26c688
pkgrel=1
arch=(any)
url="https://gitlab.com/jhoran/Laine"
@@ -13,10 +13,13 @@ provides+=($_gitname)
conflicts+=($_gitname)
pkgver() {
+ #echo 3.32.r43.gc26c688
cd ${_gitname:-$pkgname}
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
- [ ${PIPESTATUS[0]} -ne 0 ] && \
-printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #[ ${PIPESTATUS[0]} -ne 0 ] && \
+ if [ "$?" -ne "0" ]; then
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ fi
}
depends[gnomeshell]=gnome-shell