summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-04-01 21:07:09 -0500
committerHurricanePootis2024-04-01 21:07:09 -0500
commitff46f7acaf3c00c0b21ccb98f4f259d887059fea (patch)
tree27afc8387d38daa582d37b6a29b0299662cefe72
downloadaur-gnome-shell-extension-legacy-theme-auto-switcher-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aad18f93e15a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-legacy-theme-auto-switcher-git
+ pkgdesc = Change the GTK3 theme to light/dark variant based on the system color scheme
+ pkgver = r21.e935a51
+ pkgrel = 1
+ url = https://github.com/mukul29/legacy-theme-auto-switcher-gnome-extension
+ arch = any
+ license = AGPL-3.0-only
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-legacy-theme-auto-switcher
+ conflicts = gnome-shell-extension-legacy-theme-auto-switcher
+ source = gnome-shell-extension-legacy-theme-auto-switcher-git::git+https://github.com/mukul29/legacy-theme-auto-switcher-gnome-extension.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-legacy-theme-auto-switcher-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05be46695d68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+pkgname=gnome-shell-extension-legacy-theme-auto-switcher-git
+_uuid=legacyschemeautoswitcher@joshimukul29.gmail.com
+pkgver=r21.e935a51
+pkgrel=1
+pkgdesc="Change the GTK3 theme to light/dark variant based on the system color scheme"
+arch=('any')
+url="https://github.com/mukul29/legacy-theme-auto-switcher-gnome-extension"
+license=('AGPL-3.0-only')
+depends=('gnome-shell')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+ install -Dm644 extension.js metadata.json -t "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+}