summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2015-07-17 01:31:40 -0700
committerLlewelyn Trahaearn2015-07-17 01:31:40 -0700
commit626f6457d87a61f8c6763f8d7feaec3506588c9b (patch)
tree7e5752c8200711532bceca40b572ae4e3c2a4757
downloadaur-626f6457d87a61f8c6763f8d7feaec3506588c9b.tar.gz
Initial import.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
-rw-r--r--gschemas.install20
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2adb85a8a66a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-shell-extension-lockkeys-git
+ pkgdesc = Lock key state indicator for GNOME Shell.
+ pkgver = r77.76ac557
+ pkgrel = 1
+ url = https://github.com/kazysmaster/gnome-shell-extension-lockkeys
+ install = gschemas.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ depends = hicolor-icon-theme
+ provides = gnome-shell-extension-lockkeys
+ conflicts = gnome-shell-extension-lockkeys
+ source = gnome-shell-extension-lockkeys::git+https://github.com/kazysmaster/gnome-shell-extension-lockkeys.git
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-lockkeys-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66259814af21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
+# Contributor: jdarch <jda -dot- cloud -plus- archlinux -at- gmail -dot- com>
+# Contributor: mareex <marcus dot behrendt dot 86 at gmail dot com>
+
+pkgname=gnome-shell-extension-lockkeys-git
+pkgver=r77.76ac557
+pkgrel=1
+pkgdesc="Lock key state indicator for GNOME Shell."
+arch=('any')
+url="https://github.com/kazysmaster/gnome-shell-extension-lockkeys"
+license=('GPL')
+depends=('gnome-shell' 'hicolor-icon-theme')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+install="gschemas.install"
+source=("${pkgname%-*}::git+https://github.com/kazysmaster/gnome-shell-extension-lockkeys.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ _branch=master
+ cd "${srcdir}/${pkgname%-*}"
+ git checkout ${_branch}
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-*}"
+ for d in $(find ./lockkeys@vaina.lt -type d)
+ do
+ mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/$d"
+ done
+ for f in $(find ./lockkeys@vaina.lt -type f)
+ do
+ install -m0644 $f "${pkgdir}/usr/share/gnome-shell/extensions/$f"
+ done
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..61789e42d2c5
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,20 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+ instructions
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+ instructions
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+}
+
+instructions() {
+ /bin/cat << EOF
+Don't forget to restart GNOME Shell ([Alt]+[F2], r) and to enable extension
+with gnome-tweak-tool.
+EOF
+}