summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenri Muitg2021-02-20 08:17:37 +0100
committerHenri Muitg2021-02-20 08:17:37 +0100
commitd1111abf08ca316aa81b94b445c1e843f76f7f22 (patch)
tree2326901a8410941066755a3d4d302ba22fb060e5
parenta40ceacbca69f28230f69bf24e7daa039422c3a6 (diff)
downloadaur-d1111abf08ca316aa81b94b445c1e843f76f7f22.tar.gz
Revert "Fix compilation of typescript"
This reverts commit e25ab6594a19e86acc9b1efac88cc3250c9020de.
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac6a20cf3fa6..480d1b443628 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('any')
url="https://github.com/PapyElGringo/material-shell"
license=('GPL')
depends=('gnome-shell')
-makedepends=('git' 'npm')
+makedepends=('git')
optdepends=('plata-theme: gtk and shell theme'
'tela-icon-theme-git: icon theme'
'ttf-roboto: font')
@@ -20,14 +20,7 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd material-shell
- npm install --cache "${srcdir}/npm-cache"
- make compile
-}
-
package() {
- cd material-shell
- install -d $pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/
- cp -r dist/* $pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/"
+ cp -r material-shell/. "$pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/"
}