summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2021-02-07 22:22:44 +0100
committerHenri Muitg2021-02-20 08:17:48 +0100
commitd395ca60bdbd6b1728ae639c9d8708d2b5f0a334 (patch)
tree9aaae786a7cf1b2784db2a67b263a5d4fe5e0101
parentd1111abf08ca316aa81b94b445c1e843f76f7f22 (diff)
downloadaur-d395ca60bdbd6b1728ae639c9d8708d2b5f0a334.tar.gz
Fix compilation of typescript
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 480d1b443628..4c9f8eb6db72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('any')
url="https://github.com/PapyElGringo/material-shell"
license=('GPL')
depends=('gnome-shell')
-makedepends=('git')
+makedepends=('git' 'npm' 'python2')
optdepends=('plata-theme: gtk and shell theme'
'tela-icon-theme-git: icon theme'
'ttf-roboto: font')
@@ -20,7 +20,14 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd material-shell
+ npm install --cache "${srcdir}/npm-cache"
+ make compile
+}
+
package() {
- mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/"
- cp -r material-shell/. "$pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/"
+ cd material-shell
+ install -d $pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/
+ cp -r dist/* $pkgdir/usr/share/gnome-shell/extensions/material-shell@papyelgringo/
}