summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-02-07 16:16:45 +0100
committerXZS2016-02-07 16:16:45 +0100
commit2594572ba224586aca91f9a2fdbeecc6641c7b5f (patch)
treed0cd9566c0b4dfdf31af483b1ae8fe52115928eb
parenta64dc9be022dd3a08a0b75f43b95560a6be49699 (diff)
downloadaur-2594572ba224586aca91f9a2fdbeecc6641c7b5f.tar.gz
version provided non-git variant
Other packages usually depend on the package without any -git suffix. This makes it possible to als satisfy these dependency requirements when they target specific versions or version ranges.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eccf01fb9da..44ea2efd6d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Dec 6 00:42:26 UTC 2015
+# Sun Feb 7 15:16:35 UTC 2016
pkgbase = gnome-shell-extension-mediaplayer-git
pkgdesc = A mediaplayer indicator for the Gnome Shell
pkgver = r519
@@ -13,7 +13,7 @@ pkgbase = gnome-shell-extension-mediaplayer-git
makedepends = git
depends = gnome-shell
optdepends = mpdris2-git: MPD support
- provides = gnome-shell-extension-mediaplayer
+ provides = gnome-shell-extension-mediaplayer=r519
conflicts = gnome-shell-extension-mediaplayer
source = gnome-shell-extension-mediaplayer::git+https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0d680e68476..ca47f2bec0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,8 +18,8 @@ install=gschemas.install
makedepends+=('git')
source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
md5sums+=('SKIP')
-provides+=($_gitname)
-conflicts+=($_gitname)
+provides+=("$_gitname=$pkgver")
+conflicts+=("$_gitname")
pkgver() {
cd ${_gitname:-$pkgname}
git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'