summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2017-09-28 14:28:26 +0200
committerXZS2017-09-28 14:34:17 +0200
commit2f2530e2bc964ab7be11417dda9c75d9c5446763 (patch)
treefd40beec2c5b746f47d2b9210906f9c521268075
parenta19e92dd504b1796d678bff1628d5ba63489f571 (diff)
downloadaur-2f2530e2bc964ab7be11417dda9c75d9c5446763.tar.gz
patch schema location
Instead of moving the schema to the correct location after installation, the installation directives can be patched to place it there to begin with. As this change does not modify the package contents, but just how they come to be, it refrains from incrementing the pkgrel count.
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6772df533469..2272b0eba742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,6 +31,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ sed -i \
+ "/^SCHEMA_DIR/s/EXTENSION_DIR/$(
+ )get_option('prefix'), get_option('datadir'), 'glib-2.0'/" \
+ "$_gitname"/meson.build
+}
+
build() {
cd "$_gitname"
rm -rf builddir
@@ -50,12 +57,6 @@ package_01_ninja_install() {
DESTDIR="$pkgdir" ninja -C builddir install
}
-package_02_move_schema() {
- cd "$pkgdir/usr/share"
- mkdir -p glib-2.0/schemas
- mv gnome-shell/extensions/*/schemas/*.xml glib-2.0/schemas
-}
-
depends[125]=gnome-shell
package_20_version() {