summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorris Jobke2015-07-20 13:49:32 +0200
committerMorris Jobke2015-07-20 13:53:07 +0200
commit86cefebd4984f228e5ed0cf225b903693be19739 (patch)
tree5a218b70d042647d2fb1fe82f52c3069e404dfb9
downloadaur-86cefebd4984f228e5ed0cf225b903693be19739.tar.gz
migration from old AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--gnome-shell-extension-mediaplayer.install13
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d584de636e65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-shell-extension-mediaplayer-git
+ pkgdesc = A mediaplayer indicator for the Gnome Shell
+ pkgver = 3.10.r445.2b62dc0
+ pkgrel = 1
+ url = https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer
+ install = gnome-shell-extension-mediaplayer.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = gnome-common
+ makedepends = intltool
+ depends = gnome-shell
+ optdepends = mpdris2-git: MPD support
+ source = gnome-shell-extension-mediaplayer::git+https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-mediaplayer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd945f2cb891
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Morris Jobke <hey at morrisjobke dot de>
+# Contributor: alucryd <alucryd at gmail dot com>
+
+pkgname=gnome-shell-extension-mediaplayer-git
+pkgver=3.10.r445.2b62dc0
+pkgrel=1
+pkgdesc='A mediaplayer indicator for the Gnome Shell'
+arch=('any')
+url='https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer'
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git' 'gnome-common' 'intltool')
+optdepends=('mpdris2-git: MPD support')
+install=${pkgname%-*}.install
+source=("${pkgname%-*}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ printf "3.10.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ ./autogen.sh
+ ./configure --prefix='/usr' --disable-schemas-compile
+ make
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/gnome-shell-extension-mediaplayer.install b/gnome-shell-extension-mediaplayer.install
new file mode 100644
index 000000000000..29753c3fa523
--- /dev/null
+++ b/gnome-shell-extension-mediaplayer.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: