summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2017-09-28 14:28:23 +0200
committerXZS2017-09-28 14:34:06 +0200
commita19e92dd504b1796d678bff1628d5ba63489f571 (patch)
treef53664135235f1bc0ee9d08d065b198cd1b308fc
parent14678b1ce67d5d7ce45fedea34dfca2f930c9d07 (diff)
downloadaur-a19e92dd504b1796d678bff1628d5ba63489f571.tar.gz
propagate upstream update
The project now builds using meson. This not only means a new build and install pipeline, but also necessitates moving the schema to the correct place as the install script has user-local installation in mind.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 693268978cf5..d7a8de8f173c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gnome-shell-extension-mediaplayer-git
pkgdesc = A mediaplayer indicator for the Gnome Shell
- pkgver = 2.8
+ pkgver = 2.8.1
pkgrel = 1
url = https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer
install = gschemas.install
arch = any
license = GPL2
- makedepends = gnome-common
+ makedepends = meson
makedepends = intltool
makedepends = git
depends = gnome-shell
optdepends = mpdris2-git: MPD support
- provides = gnome-shell-extension-mediaplayer=2.8
+ provides = gnome-shell-extension-mediaplayer=2.8.1
conflicts = gnome-shell-extension-mediaplayer
source = gnome-shell-extension-mediaplayer::git+https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aefff62c3a11..6772df533469 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
# You may find it convenient to file issues and pull requests there.
pkgname=gnome-shell-extension-mediaplayer-git
-pkgver=2.8
+pkgver=2.8.1
pkgrel=1
pkgdesc='A mediaplayer indicator for the Gnome Shell'
arch=('any')
url='https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer'
license=('GPL2')
-makedepends=('gnome-common' 'intltool')
+makedepends=('meson' 'intltool')
optdepends=('mpdris2-git: MPD support')
install=gschemas.install
@@ -33,9 +33,9 @@ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
build() {
cd "$_gitname"
- ./autogen.sh
- ./configure --prefix='/usr' --disable-schemas-compile
- make
+ rm -rf builddir
+ meson builddir --prefix='/usr'
+ ninja -C builddir
}
package() {
@@ -45,9 +45,15 @@ package() {
done
}
-package_01_make_install() {
+package_01_ninja_install() {
cd "$_gitname"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" ninja -C builddir install
+}
+
+package_02_move_schema() {
+ cd "$pkgdir/usr/share"
+ mkdir -p glib-2.0/schemas
+ mv gnome-shell/extensions/*/schemas/*.xml glib-2.0/schemas
}
depends[125]=gnome-shell