summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikul─Śnas2017-09-28 14:28:43 +0200
committerXZS2017-09-28 14:34:21 +0200
commitd93164eacdb83e13fd787774744ff54d84eba7ea (patch)
tree9e4808f83a55cfa8cd8c3cf602cad7d9160f935e
parent664ae0546f4d75fe0f1e64464e299f3a6d30be2e (diff)
downloadaur-d93164eacdb83e13fd787774744ff54d84eba7ea.tar.gz
relax dependency
For MPD to speak MPRIS, just the general mpdris software is needed, not a specifically new version from Git, so the dependency can be relaxed. According to the Arch Linux VCS package guidelines [1] it can be expected that the mpdris2-git package provides mpdris2, thus keeping all package relations intact. [1]: https://wiki.archlinux.org/index.php/VCS_package_guidelines
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7a8de8f173..0476e3470a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-mediaplayer-git
pkgdesc = A mediaplayer indicator for the Gnome Shell
pkgver = 2.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer
install = gschemas.install
arch = any
@@ -10,7 +10,7 @@ pkgbase = gnome-shell-extension-mediaplayer-git
makedepends = intltool
makedepends = git
depends = gnome-shell
- optdepends = mpdris2-git: MPD support
+ optdepends = mpdris2: MPD support
provides = gnome-shell-extension-mediaplayer=2.8.1
conflicts = gnome-shell-extension-mediaplayer
source = gnome-shell-extension-mediaplayer::git+https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer
diff --git a/PKGBUILD b/PKGBUILD
index c70bd878313..97b0617e11a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
pkgname=gnome-shell-extension-mediaplayer-git
pkgver=2.8.1
-pkgrel=1
+pkgrel=2
pkgdesc='A mediaplayer indicator for the Gnome Shell'
arch=('any')
url='https://github.com/eonpatapon/gnome-shell-extensions-mediaplayer'
license=('GPL2')
makedepends=('meson' 'intltool')
-optdepends=('mpdris2-git: MPD support')
+optdepends=('mpdris2: MPD support')
install=gschemas.install
makedepends+=('git')