summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2015-10-11 17:50:46 +0200
committerXZS2015-10-11 17:50:46 +0200
commit09be2144028f07fbae898ff6d1813ee175a21ea4 (patch)
tree6655317e0a19942b2b655132484001f2072dbfdf
parenta30641e23a71a9bba2a2824e94c617b515f05e3b (diff)
downloadaur-09be2144028f07fbae898ff6d1813ee175a21ea4.tar.gz
move to git source
The package is not maintained by its original author since a few gnome-shell versions. GitHub user p91paul adapted it for the current version, so pulling from his repository ensures further compatibility.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aecdb257afe..eb879c8652a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
-pkgbase = gnome-shell-extension-middleclickclose
+pkgbase = gnome-shell-extension-middleclickclose-git
pkgdesc = Close windows with a button click (the middle one by default) when in overview mode
- pkgver = 6
- pkgrel = 2
- url = http://sourceforge.net/projects/buttons-to-panel/
+ pkgver = r16
+ pkgrel = 1
+ url = https://github.com/p91paul/middleclickclose
install = gschemas.install
arch = any
- license = unknown
+ license = GPL
+ makedepends = git
depends = gnome-shell
- source = gnome-shell-extension-middleclickclose.zip::http://sourceforge.net/projects/mt-miscellaneous/files/gnome-extensions/3.16/middleclickclose@paolo.tranquilli.gmail.com.v6.shell-extension.zip/download
- md5sums = e7ea5800d8408ea33496cdac01a058f6
+ provides = gnome-shell-extension-middleclickclose
+ conflicts = gnome-shell-extension-middleclickclose
+ source = gnome-shell-extension-middleclickclose::git+https://github.com/p91paul/middleclickclose
+ md5sums = SKIP
-pkgname = gnome-shell-extension-middleclickclose
+pkgname = gnome-shell-extension-middleclickclose-git
diff --git a/PKGBUILD b/PKGBUILD
index 236b5fc4def2..26539c2699d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,25 @@
# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/gnome-shell-extensions>.
# You may find it convenient to file issues and pull requests there.
-pkgname=gnome-shell-extension-middleclickclose
-_extname='middleclickclose@paolo.tranquilli.gmail.com'
-pkgver=6
-pkgrel=2
+pkgname=gnome-shell-extension-middleclickclose-git
+pkgver=r16
+pkgrel=1
pkgdesc="Close windows with a button click (the middle one by default) when in overview mode"
arch=(any)
-url='http://sourceforge.net/projects/buttons-to-panel/'
-license=(unknown)
-source=("${pkgname}.zip::http://sourceforge.net/projects/mt-miscellaneous/files/gnome-extensions/3.16/${_extname}.v6.shell-extension.zip/download")
-md5sums=('e7ea5800d8408ea33496cdac01a058f6')
+url='https://github.com/p91paul/middleclickclose'
+license=(GPL)
+makedepends+=('git')
+source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
+md5sums+=('SKIP')
+provides+=($_gitname)
+conflicts+=($_gitname)
+pkgver() {
+ cd ${_gitname:-$pkgname}
+ git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
+ [ ${PIPESTATUS[0]} -ne 0 ] && \
+printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
do