summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:51:04 +0200
committerXZS2016-04-22 11:51:04 +0200
commitda1de0999ef1371311f60dcedad7042b0c0435ff (patch)
tree9b46013731b45d430fc5371dd1a1f40450fb119d
parent5d3d8ba8fdfa566ef01c047f19be0804fcf8c667 (diff)
downloadaur-da1de0999ef1371311f60dcedad7042b0c0435ff.tar.gz
fix version comparison
Comparing the minor version to a string of minor and major will never succeed. Originally, a restriction on the current shell version was omitted for historical reasons - most packages did so when dependencies were defined manually. This now turns into a concious decision to - permit the usage of the extension in instable gnome-shell versions - the ones with odd minor version numbers - where incompatibilities are introduced gradually. - ease the transition from one stable gnome-shell version - the ones with even minor version numbers - to the next. In an ideal world, all extensions should have been updates before the update hits the repositories. But as Arch is quite more on the edge than developers of some of the extensions, this is not the case more often than not.
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78287e88a47c..87c73c3f7bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,7 +57,7 @@ package_20_version() {
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"
- if [ "3.$max" != $(
+ if [ "$max" != $(
gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
) ]; then
depends+=("gnome-shell<3.$((${max%%.*} + 1))")