summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 13:58:16 +0100
committerXZS2016-11-01 13:58:16 +0100
commitea046bf40480ceb67403383df66da4d99fc61081 (patch)
treeb281f39143ccef29dea819da3e3cb615192c4b10
parent2f57fe1cf0829724df182cc4ac699202e49bf5a6 (diff)
downloadaur-ea046bf40480ceb67403383df66da4d99fc61081.tar.gz
choose newest extension source
Some extensions authors introduce build steps required before installing. Their execution normally produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d531e4871e8..7f36f937964e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,7 +33,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}